POJ - 1392 Ouroboros Snake (欧拉回路的应用)

Description

Ouroboros is a mythical snake from ancient Egypt. It has its tail in its mouth and continously devours itself.

The Ouroboros numbers are binary numbers of 2^n bits that have the property of "generating" the whole set of numbers from 0 to 2^n - 1. The generation works as follows: given an Ouroboros number, we place its 2^n bits wrapped in a circle. Then, we can take 2^n groups of n bits starting each time with the next bit in the circle. Such circles are called Ouroboros circles for the number n. We will work only with the smallest
Ouroboros number for each n.

Example: for n = 2, there are only four Ouroboros numbers. These are 0011;0110;1100; and 1001. In this case, the smallest one is 0011. Here is the Ouroboros circle for 0011:

The table describes the function o(n;k) which calculates the k-th number in the Ouroboros circle of the smallest Ouroboros number of size n. This function is what your program should compute.

Input

The input consists of several test cases. For each test case, there will be a line containing two integers n and k (1<=n<=15; 0<=k<2^n). The end of the input file is indicated by a line containing two zeros. Don抰 process that line.

Output

For each test case, output o(n;k) on a line by itself.

Sample Input

2 0
2 1
2 2
2 3
0 0

Sample Output

0
1
3
2

题意:让你找个字典序最小的序列使得排成环旋转后取n个,最后可以取到[0-2^n)的所有数。

思路:欧拉回路的应用,首先为了找最短,所有我们希望这个数的后n-1位和下一个数的前n-1位是相同的,只有他们的头和尾不一样,所以我们有每添加一位就可以构成一个新的数,那么这两个数就能通过这位来连接,我们可以先枚举出所有的节点,然后对应产生边,我们最后要跑完所有的边且回到原点,而这就是欧拉回路了

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <vector>
using namespace std;
const int maxn = 1<<16;

struct Edge {
	int v, via;
	int vis;
}; 
vector<Edge> ve[maxn];
int path[maxn<<1];
int n, k, cnt;

void init() {
	for (int i = 0; i < maxn; i++)
		ve[i].clear();
}

void dfs(int cur) {
	for (int i = 0; i < ve[cur].size(); i++)
		if (!ve[cur][i].vis) {
			ve[cur][i].vis = 1;
			dfs(ve[cur][i].v);
			path[++cnt] = ve[cur][i].via + '0';
		}
	return;
}

int main() {
	while (scanf("%d%d", &n, &k) != EOF && n+k) {
		int len = n;
		n = (1<<(n-1)) - 1;
		init();
		Edge tmp;
		for (int i = 0; i <= n; i++) {
			int t = (i<<1) - ((i&(1<<(len-2)))<<1);
			tmp.v = t;
			tmp.via = 0;
			tmp.vis = 0;
			ve[i].push_back(tmp);
			t += 1;
			tmp.v = t;
			tmp.via = 1;
			tmp.vis = 0;
			ve[i].push_back(tmp);
		}
		cnt = -1;
		dfs(n);
		path[++cnt] = '\0';
		reverse(path, path+cnt);
		int ans = 0;
		for (int i = k, j = 1; j <= len; j++, i++) 
			ans = (ans<<1) + (path[i%cnt]-'0');
		printf("%d\n", ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值