HDU - 4803 Poor Warehouse Keeper(贪心)

Description

Jenny is a warehouse keeper. He writes down the entry records everyday. The record is shown on a screen, as follow: 

There are only two buttons on the screen. Pressing the button in the first line once increases the number on the first line by 1. The cost per unit remains untouched. For the screen above, after the button in the first line is pressed, the screen will be: 

The exact total price is 7.5, but on the screen, only the integral part 7 is shown. 
Pressing the button in the second line once increases the number on the second line by 1. The number in the first line remains untouched. For the screen above, after the button in the second line is pressed, the screen will be: 

Remember the exact total price is 8.5, but on the screen, only the integral part 8 is shown. 
A new record will be like the following: 

At that moment, the total price is exact 1.0. 
Jenny expects a final screen in form of: 

Where x and y are previously given. 
What’s the minimal number of pressing of buttons Jenny needs to achieve his goal?
 

Input

There are several (about 50, 000) test cases, please process till EOF. 
Each test case contains one line with two integers x(1 <= x <= 10) and y(1 <= y <= 10  9) separated by a single space - the expected number shown on the screen in the end.
 

Output

For each test case, print the minimal number of pressing of the buttons, or “-1”(without quotes) if there’s no way to achieve his goal.
 

Sample Input

    
    
1 1 3 8 9 31
 

Sample Output

    
    
0 5 11

Hint

 For the second test case, one way to achieve is: (1, 1) -> (1, 2) -> (2, 4) -> (2, 5) -> (3, 7.5) -> (3, 8.5) 
         

题意:有x和y两个值,分别代表数量和总价,有两个操作:1.总价+1,数量不变,但是单价会变;2.数量+1,总价也跟着变,单价不变,求到达指定X,Y的最小操作次数

思路:贪心的题目,首先,我们明确单价是一直在变大的,我们也可以求出最大的单价,然后贪心的去求每个不同数量对应要增加的总价次数

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const double eps = 1e-9;

double x, y;

int main() {
	while (scanf("%lf%lf", &x, &y) != EOF) {
		if (x > y) {
			printf("-1\n");
			continue;
		}
		double k = (y+1-eps) / x;
		double tmp = 1;
		int cnt = (int) x - 1;
		for (int i = 1; i <= (int)x; i++) {
			double t = i * k;
			int u = (int) (t - tmp);
			tmp += u;
			tmp = tmp * (i+1) / i;
			cnt += u;
		}
		printf("%d\n", cnt);
	}
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值