poj1836 Alignment

Alignment

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 3
Problem Description
In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity.  

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.  
 

Input
On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).  

There are some restrictions:  
2 <= n <= 1000  
the height are floating numbers from the interval [0.5, 2.5]  
 

Output
The only line of output will contain the number of the soldiers who have to get out of the line.
 

Sample Input
  
  
8 1.86 1.86 1.30621 2 1.4 1 1.97 2.2
 

Sample Output
  
  
4
 
 
 
题目大意就是有一排士兵站成一排,现在让最少数量的士兵滚蛋,使剩下的士兵向左或想有看时视线不被阻挡(就是高)。。
这么一看最终结果要求队伍是先递增在递减的。。。
于是很容易想到这道题和很久很久一前noip里面的那个合唱队型挺像。。。
但是按照那样做就错了。。。因为在顶端的两个人是可以身高相同的,比如1 2 3 3 2 1。。。。
但其实还是差不多一个意思。。在这里显然不能用o(n^3)的算法
那么我们令a[i]表示从1到i的最长不下降子序列,令b[i]表示i到n的最长降序列然后再a[i]和b[j]里选和最大的(i>j)然后答案为n-max
代码如下
#include<iostream>
using namespace std;

int main()
{
	int f1[1001],f2[1001],i,j,n,max=0,ans;
	double a[1001];
    cin>>n;
	for (i=1;i<=n;i++)
	{
		f1[i]=1;
		f2[i]=1;
	}
	for (i=1;i<=n;i++)
		cin>>a[i];
	for (i=1;i<=n;i++)
		for (j=1;j<=i-1;j++)
			if (a[j]<a[i]&&f1[i]<f1[j]+1)
				f1[i]=f1[j]+1;

	

	for (i=n;i>=1;i--)
		for (j=i+1;j<=n;j++)
			if (a[j]<a[i]&&f2[i]<f2[j]+1)
				f2[i]=f2[j]+1;
	for (i=1;i<=n;i++)
		for (j=i+1;j<=n;j++)
		max=max>f1[i]+f2[j]?max:f1[i]+f2[j];
	
	ans=n-max;
	cout<<ans;
	return 0;
}

 
 
 
 
妈蛋英语要学好。。一开始按合唱队型做了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值