poj 1118

                                          Lining Up
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 20706 Accepted: 6520

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

Source

这是一个暴力搜索的题目。
数据量看似很大,但是实际上用O(n3)的算法也可以AG。
题目意思是在最多700个点中找寻一条直线,使得它经过的点最多。
很容易想到依次算出每两个点之间的斜率,然后找寻斜率相同的点对计数。
但是在C++中,如果想要计算斜率就要用到double型,而double型不能直接比较大小,只能用A-B<10e-16来判断两个数字是否相等,而且对于相距较近的数据,是无法判断的。
显然想到用两个向量的叉乘判断共线,即x1*y1-x2*y2=0可以初始化(a[i][j][0],a[i][j][1])表示点i,j构成的向量。
注意题目是多组数据啊→_→。。。
代码如下
#include<iostream>
using namespace std;
int a[701][701][2],i,j,sum,ans=0;
int judge(int x,int y)
{
	int m,n;
	m=a[i][x][1]*a[i][y][0];
	n=a[i][x][0]*a[i][y][1];
	if (m==n)
		return 1;
	else return 0;
}


int main()
{
	int j,k,n,x[701],y[701];
	cin>>n;
	while (n!=0)
	{
		ans=0;
		for (i=1;i<=n;i++)
			cin>>x[i]>>y[i];
		for (i=1;i<=n;i++)
			for (j=1;j<=n;j++)
			{
				a[i][j][0]=x[i]-x[j];
				a[i][j][1]=y[i]-y[j];
			}
		for (i=1;i<=n;i++)
			for (j=1;j<=n&&j!=i;j++)
			{
				sum=0;
				for (k=1;k<=n&&k!=i&&k!=j;k++)
					if (judge(j,k)==1) sum++;
				if (sum>ans) ans=sum;
			}
			cout<<ans+2<<endl;
			cin>>n;
			
	}
	return 0;
}
		

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值