hdu4432 Sum of divisors(数论)

Sum of divisors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2063    Accepted Submission(s): 718


Problem Description
mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!
But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?" mmm get stuck and she's asking for your help.
Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different.
Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.
 

Input
Multiple test cases, each test cases is one line with two integers.
n and m.(n, m would be given in 10-based)
1≤n≤10 9
2≤m≤16
There are less then 10 test cases.
 

Output
Output the answer base m.
 

Sample Input
  
  
10 2 30 5
 

Sample Output
  
  
110 112
Hint
Use A, B, C...... for 10, 11, 12...... Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is 1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + .... = 6 = 110 under base 2.
 

Source
 
现在看觉得挺简单的,第一眼看时觉得挺难就没做,谁知道人家一下就AC了,直接一般的方法做加一点优化就行了
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
int vet[10000];
int main()
{
    int n,m,all,sum,s,ii,i,t;
    char str[17]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E'};
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==1)
        {
            printf("1\n");
            continue;
        }
        all=n;sum=0;
        for(i=2;i<all;i++)
        {
            if(n%i==0)
            {
                all=n/i;//注意这一步优化,最关键的一步,如果i是n的因数,那么我们直接把i和n/i一起算了,i的上界变成了n/i-1
               // printf("%d %d",i,n/i);
                s=0;
                ii=i;
                while(ii)
                {
                    t=ii%m;
                    s+=t*t;
                    ii=ii/m;
                }
                ii=n/i;
                while(ii)
                {
                    t=ii%m;
                    s+=t*t;
                    ii=ii/m;
                }
                sum+=s;
            }
        }
         s=0;
        ii=n;
        while(ii)
        {
            t=ii%m;
            s+=t*t;
            ii=ii/m;
        }
        sum+=s;
        sum++;
        t=0;
        while(sum)
        {
           vet[t++]=sum%m;
           sum=sum/m;
        }
        for(i=t-1;i>=0;i--)
        {
            printf("%c",str[vet[i]]);
        }

        printf("\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值