hdu4089 Activation (概率dp)

Activation

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 999    Accepted Submission(s): 365


Problem Description
After 4 years' waiting, the game "Chinese Paladin 5" finally comes out. Tomato is a crazy fan, and luckily he got the first release. Now he is at home, ready to begin his journey.
But before starting the game, he must first activate the product on the official site. There are too many passionate fans that the activation server cannot deal with all the requests at the same time, so all the players must wait in queue. Each time, the server deals with the request of the first player in the queue, and the result may be one of the following, each has a probability:
1. Activation failed: This happens with the probability of p1. The queue remains unchanged and the server will try to deal with the same request the next time.
2. Connection failed: This happens with the probability of p2. Something just happened and the first player in queue lost his connection with the server. The server will then remove his request from the queue. After that, the player will immediately connect to the server again and starts queuing at the tail of the queue.
3. Activation succeeded: This happens with the probability of p3. Congratulations, the player will leave the queue and enjoy the game himself.
4. Service unavailable: This happens with the probability of p4. Something just happened and the server is down. The website must shutdown the server at once. All the requests that are still in the queue will never be dealt.
Tomato thinks it sucks if the server is down while he is still waiting in the queue and there are no more than K-1 guys before him. And he wants to know the probability that this ugly thing happens.
To make it clear, we say three things may happen to Tomato: he succeeded activating the game; the server is down while he is in the queue and there are no more than K-1 guys before him; the server is down while he is in the queue and there are at least K guys before him.
Now you are to calculate the probability of the second thing.
 

Input
There are no more than 40 test cases. Each case in one line, contains three integers and four real numbers: N, M (1 <= M <= N <= 2000), K (K >= 1), p1, p2, p3, p4 (0 <= p1, p2, p3, p4 <= 1, p1 + p2 + p3 + p4 = 1), indicating there are N guys in the queue (the positions are numbered from 1 to N), and at the beginning Tomato is at the Mth position, with the probability p1, p2, p3, p4 mentioned above.
 

Output
A real number in one line for each case, the probability that the ugly thing happens.
The answer should be rounded to 5 digits after the decimal point.
 

Sample Input
  
  
2 2 1 0.1 0.2 0.3 0.4 3 2 1 0.4 0.3 0.2 0.1 4 2 3 0.16 0.16 0.16 0.52
 

Sample Output
  
  
0.30427 0.23280 0.90343
 

Source
 

题目:仙5的激活序列。有以下4种情况:

1、注册失败,但是不影响队列顺序 ,概率为p1

2、连接失败,队首的人排到队尾,概率为p2

3、注册成功,队首离开队列,概率为p3

4、服务器崩溃,激活停止,概率为p4

求主角的位置在K以内,而且服务器崩溃的概率

比较容易想到一个二维DP

dp[i][j]表示队列总共有i个人,主角站在第j个位置时,所求事件发生的概率。

那么可以写出转移方程

dp[i][1]=dp[i][1]*p1+dp[i][i]*p2+p4       (可能自己注册失败,第二次继续;可能自己连接失败,回到队尾;服务器崩溃)

dp[i][j]=dp[i][j]*p1+dp[i][j-1]*p2+dp[i-1][j-1]*p3+p4  (j<=k)(可能队首的人注册失败,第二次继续;可能队首连接失败,回到队尾;队首注册成功,出队;服务器崩溃)

dp[i][j]=dp[i][j]*p1+dp[i][j-1]*p2+dp[i-1][j-1]*p3    (j>k)(可能队首的人注册失败,第二次继续;可能队首连接失败,回到队尾;队首注册成功,出队)//此时服务器若崩溃则满足需要的状态

稍微整理下,把dp[i][j]放到一边

而且令  p21=p2/(1-p2)  p31=p3/(1-p1)  p41=p4/(1-p1);

dp[i][1]=dp[i][i]*p21 +p41

dp[i][j]=dp[i][j-1]*p21 +dp[i-1][j-1]*p31+p41;        (j<=k)

dp[i][j]=dp[i][j-1]*p21 +dp[i-1][j-1]*p31;             (j>k)

可以发现后面的部分dp[i-1][j-1]在递推的时候都可以解决,我们令后面的部分为c[j](此时i固定)

则c[1]=p41      c[2]=dp[i-1][j-1]*p31+p41 …………

dp[i][j]就可以由dp[i][j-1]推出,但是可以发现这里产生 了一个循环,dp[i][1]又是由dp[i][i]得来的。

范围如此之大,肯定不能用高斯消元来做,而且也没必要。

我们把式子合并,迭代一下,这样就能先解出dp[i][i],进而可以得到dp[i][1],剩下的就可以递推出来了

dp[i][i]=dp[i][i]*p21^i+c[2]^p21^(i-1)……c[i]+p41*p21

题目要求的便是dp[n][m];

在网上看的讲解 自己又加了点注释 

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define MIN 1e-5
double dp[2005][2005],c[2005];
int main()
{
    int n,m,k,i,j;
    double p1,p2,p3,p,p4,p41,p31,p21,temp;
    while(cin>>n>>m>>k>>p1>>p2>>p3>>p4)
    {
        if(p4<MIN)
        {
            puts("0.00000");
            continue ;
        }
        p21=p2/(1-p1);
        p31=p3/(1-p1);
        p41=p4/(1-p1);
        dp[1][1]=p4/(1-p1-p2);
        for(i=2;i<=n;i++)
        {
            for(j=2;j<=k;j++)
                c[j]=dp[i-1][j-1]*p31+p41;
            for(j=k+1;j<=i;j++)
                c[j]=dp[i-1][j-1]*p31;
            p=1;
            temp=0;
            for(j=i;j>1;j--)//必须这样写
            {
                temp+=p*c[j];
                p*=p21;
            }
            dp[i][i]=(temp+p*p41)/(1-p*p21);
            dp[i][1]=p21*dp[i][i]+p41;
            for(j=2;j<i;j++)
                dp[i][j]=dp[i][j-1]*p21+c[j];
        }
        printf("%.5f\n",dp[n][m]);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值