hdu4572 Bottles Arrangement(找规律)

Bottles Arrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 224    Accepted Submission(s): 176


Problem Description
  Hunan cuisine is really wonderful! But if you don’t like spicy food, you will feel terrible since it can be hard for you to find any food without hot pepper here. Big Fan is a student from the north who was not fit to the spicy food in Changsha. He became thinner and thinner because eating little food and maintained his life mostly by drinking water. One day, he found that the wine in Hunan is pretty good, such as Jiugui, Liuyang River, Shaoyang Daqu and so on. He got addicted to it and became an alcoholic, leading a depressed life. 
  Now N days have passed and he is sobered. He is surprised to find that there are exactly N×M bottles around him. Another amazing fact is that there are N bottles with height 1 and N bottles with height 2 … N bottles with height M.
Now he is interested in playing with these bottles. He wants to arrange all these bottles in a rectangle with M rows and N columns which satisfied: 
(1)In any column, there are no bottles with same height; 
(2)In any row, the height difference between any two adjacent bottles is no more than 1. 
  He defined a strange function Y which equals the maximum value of the total height of any single row. He is addicted in arranging these rubbish bottles to find the minimal Y. You know that he cannot solve it with his pour IQ. You are his friend and can’t endure his decadence any more. So you decide to help him solve this problem and then bring him back to study.
 

Input
  There are several test cases. For each case, the input contains one line with two integers M and N (1< M <= 10000, 3 <= N < 2×M, It is guaranteed that N is always odd).
  The input will finish with the end of file.
 

Output
  For each test case, print the minimal Y in single line.
 

Sample Input
  
  
3 3 3 5
 

Sample Output
  
  
8 11
Hint
For the first case the solution is: 1 2 3 2 1 1 3 3 2
 

Source
 

这题写起来很简单,可是推理起来不简单,比赛时只觉得不简单就没做它,谁知道这么短的代码就能过了,只能说自己能力不够

这个算是找规律的,当时就直接跳过了。把m,m,m-1,m-1,m-2,m-2,m-3,m-3..........前n项求出来输出即可

关于这个题的证明,网上可以找到,有人看了,证明这个写了两页,反正比这个代码要长很多的

#include<stdio.h>
int main()
{
	int n,m,i,sum,j;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		sum=0;
		for(i=0;i<=n/2;i++)
		{
			sum+=(m-i)*2;
		}
		sum-=m-i+1;
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值