POJ 2342 Anniversary party


  
  
Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3235 Accepted: 1796

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:  L K  It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line  0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

 

题意:一棵树,相邻两个节点不能同时出现,问总共能出现的节点的最大值。

解析:树状dp入门。



//vector容器用来存图特方便
#include<stdio.h>
#include<string.h>
#include<vector>
#define max(x,y) x<y?y:x
#define INF 6005
using namespace std;

int n,rate[INF],de[INF],dp[INF][2];
vector<int>vec[INF];//相当于二维数组

void dfs(int x)
{
	dp[x][1] = rate[x];		//相当于把叶子节点给初始了。因为dp初始化为0,所以叶子节点的dp[x][0]为0,而且叶子节点dp[x][1]就
							//等于rate[x]。对于非叶子节点这些没有影响
	int len = vec[x].size();
	for(int i = 0 ; i < len; i ++)	//程序的结构也相当不错
		dfs(vec[x][i]);
	for(int i = 0; i < len; i ++)
	{
		dp[x][0] += max(dp[vec[x][i]][0],dp[vec[x][i]][1]);
		dp[x][1] += dp[vec[x][i]][0];		//dpx[x][1]初始值为rate[x],所以不需要再加了
	}
}

int main()
{
	while(scanf("%d",&n) != EOF)
	{
		int a,b;
		memset(rate,0,sizeof(0));
		memset(de,0,sizeof(de));
		memset(dp,0,sizeof(dp));
		for(int i = 1 ; i <= n ; i++)
		{
			vec[i].clear();
			scanf("%d",&rate[i]);
		}

		while(scanf("%d%d",&a,&b) && (a != 0|| b != 0))
		{
			vec[b].push_back(a);//b能到达a
			de[a] = 1;			//用来记录是否为根节点
		}

		for(int i = 1; i <= n ; i ++)
			if(!de[i])
			{
				dfs(i);
				printf("%d\n",max(dp[i][0],dp[i][1]));
				break;
			}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值