POJ 2479 Maximum sum (同POJ 2593 Max Sequence)

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30031 Accepted: 9177

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU
 
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define MAX 50002
#define NEG_INF -999999999

int a[MAX],sum1[MAX],sum2[MAX];

int main()
{
	int t,n,i,ans;
	int s1,s2,max1,max2;

	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d",&n);
			for(i=0;i<n;i++)
			{
				scanf("%d",&a[i]);
				sum1[i]=sum2[i]=NEG_INF;
			}
			ans=s1=s2=max1=max2=NEG_INF;
			for(i=0;i<n-1;i++)
			{
				if(s1>0) s1+=a[i];
				else s1=a[i];
				if(max1<s1) max1=s1;
				sum1[i]=max1;

				if(s2>0) s2+=a[n-i-1];
				else s2=a[n-i-1];
				if(max2<s2) max2=s2;
				sum2[n-i-1]=max2;
			}
			for(i=0;i<n-1;i++)
				ans=ans>(sum1[i]+sum2[i+1]) ? ans : (sum1[i]+sum2[i+1]);
			printf("%d\n",ans);
		}
	}
	return 0;
}


思路:
求最大字段和的变形,若分成两段一遍遍求会超时,注意优化方法
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值