【动态规划】poj2479 Maximum sum && poj2593 Max Sequence(求两段不相交字串的最大和)

本文介绍了如何使用动态规划解决POJ2479和POJ2593两道题目,这两题都涉及到找出字符串中两段不相交子串的最大和。通过枚举分割点并维护两个方向的最大子串和,可以得到最大值。动态规划状态转移方程为dp[i] = max{dp[i-1] + a[i], a[i]},同时计算lmax和rmax辅助数组来优化解题过程。" 81806598,5642142,合并k个排序链表,"['数据结构', '链表操作', '排序算法']
摘要由CSDN通过智能技术生成

两道题都是求两段不相交的子串最大和

2479:

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint


枚举两个子串的分割点i,1<=i<=n,分别求两个串的最大子串,求出的最大值即为所求。
dp[i]表示以位置i结束的子串的最大连续和时,则dp[i]=max{dp[i-1]+a[i],a[i]}

lmax[i]表示串a[1]-a[i]的最大子串和的值,则lmax[i]=max{lmax[i-1],dp[i]}

同理,

dp[i]表示以位置i开始的子串的最大连续和时,则dp[i]=max{dp[i+1]+a[i],a[i]}

rmax[i]表示串a[i+1]-a[n]的最大子串和的值,则rmax[i]=max{rmax[i+1],dp[i]}


#include<stdio.h>
#include<algorithm>
#include<string.h>
#define N 50005
#define inf -99999999
using namespace std;
int dp[N],rmax[N],lmax[N],a[N];//dp[i]第i位时的字串最大连续和,lmax[i]表示串a[1]-a[i]的最大子串和的值,rmax[i]表示串a[i+1]-a[n]的最大子串和的值
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,0,sizeof(dp));
        memset(lmax,0,sizeof(lmax));
        memset(rmax,0,sizeof(rmax));
        int n;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        dp[0]=inf;//初始化为最小
        dp[n+1]=inf;
        lmax[0]=inf;
        rmax[n+1]=inf;
        for(int i=1; i<=n; i++)//从左往右正向找dp[i],lmax[i]
        {
            dp[i]=max(dp[i-1]+a[i],a[i]);
            lmax[i]=max(dp[i],lmax[i-1]);
        }
        for(int i=n; i>=1; i--)//从右往左正向找dp[i],rmax[i]
        {
            dp[i]=max(a[i],dp[i+1]+a[i]);
            rmax[i]=max(dp[i],rmax[i+1]);
        }
        int ans=inf;
        for(int i=1; i<=n-1; i++)//枚举分割点i
        {
            ans=max(ans,lmax[i]+rmax[i+1]);
        }
        printf("%d\n",ans);
    }
}


poj2593 Max Sequence和2479一样,
只是将数组开大,T组数据换成多组


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值