POJ 2479 Maximum sum ( DP )和POJ 2593 Max Sequence(DP)

Maximum sum

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 47392 Accepted: 14601

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1
10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.

解题思路:

这里我们分别从前往后(dp1)和从后往前(dp2)求解最大连续子串和,然后设置一个rtm[i]代表取后i个元素之中最大连续子串的和,最大的dp1[i - 1] + rtm[i]。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=100000+100;
const int inf=0x3fffffff;
int n;
int a[MAXN],b[MAXN],dp1[MAXN],dp2[MAXN];
int main()
{
	int t;
	scanf("%d", &t);
    while(t--)
    {
		scanf("%d", &n);
        dp1[0]=dp2[n+1]=-inf;
        b[0]=b[n+1]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[i]=max(0,b[i-1])+a[i];
            dp1[i]=max(dp1[i-1],b[i]);
        }
        for(int i=n;i>=1;i--)
        {
            b[i]=max(0,b[i+1])+a[i];
            dp2[i]=max(dp2[i+1],b[i]);
        }
        int ans=-inf;
        for(int i=1;i<n;i++)
            ans=max(ans,dp1[i]+dp2[i+1]);
        printf("%d\n",ans);
    }
    return 0;
}

 

Max Sequence

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 18867 Accepted: 7886

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N).


You should output S.

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40

解题思路

和上一题思路一样

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=100000+100;
const int inf=0x3fffffff;
int n;
int a[MAXN],b[MAXN],dp1[MAXN],dp2[MAXN];
int main()
{
    while(~scanf("%d",&n) && n)
    {
		scanf("%d", &n);
        dp1[0]=dp2[n+1]=-inf;
        b[0]=b[n+1]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[i]=max(0,b[i-1])+a[i];
            dp1[i]=max(dp1[i-1],b[i]);
        }
        for(int i=n;i>=1;i--)
        {
            b[i]=max(0,b[i+1])+a[i];
            dp2[i]=max(dp2[i+1],b[i]);
        }
        int ans=-inf;
        for(int i=1;i<n;i++)
            ans=max(ans,dp1[i]+dp2[i+1]);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值