POJ 2653 Pick-up sticks

Pick-up sticks
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8012 Accepted: 2946

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.

Source

 
题意:
判断陆续丢下的一系列木棍是否相交,输出最顶部的木棍
 
代码:
#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#define MAX 100010
#define eps 1e-8
using namespace std;

typedef struct
{
	double x,y;
}stick;

stick head[MAX],tail[MAX];
bool judge[MAX];
int N;

double make(double a,double b,double c,double d)
{
	return a*d-b*c;
}

double Cross(stick &a,stick &b,stick &c)
{
	return make(b.x-a.x,b.y-a.y,c.x-a.x,c.y-a.y);
}

int cmp(double x)
{
	if(fabs(x)<eps) return 0;
	else 
	{
		return x>0 ? 1: -1;
	}
}

bool isCross(int i,int j)
{
	return (cmp(Cross(head[i],tail[i],head[j]))^cmp(Cross(head[i],tail[i],tail[j])))==-2     //1^-1==-2
		&& (cmp(Cross(head[j],tail[j],head[i]))^cmp(Cross(head[j],tail[j],tail[i])))==-2;
}

//若两木棍相交,Cross所得叉积定为一正一负,则cmp返回1和-1,位异或后得-2

int main()
{
	while(scanf("%d",&N)!=EOF && N)
	{
		for(int i=1;i<=N;i++)
			scanf("%lf%lf%lf%lf",&head[i].x,&head[i].y,&tail[i].x,&tail[i].y);

		memset(judge,true,sizeof(judge));
		for(int i=1;i<N;i++)
			for(int j=i+1;j<=N;j++)
				if(isCross(i,j))
				{
					judge[i]=false;
					break;
				}

		printf("Top sticks:");
		int flag=0;
		for(int i=1;i<=N;i++)
		{
			if(judge[i])
			{
				if(flag==1) printf(",");
				printf(" %d",i);	
				flag=1;
			}
		}

		printf(".\n");
	}
	return 0;
}

思路:
按投下顺序,从头到尾暴力求解,将每根棍子与后投下的相比较,这样不会超时
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值