POJ 1200 Crazy Search

Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20543 Accepted: 5808

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

 
题意:
输入一个有nc个不同字母的字符串
求其有多少个n个字母构成的子串
 
思路:
Rabin-Karp算法 将字符串转化为数字
再Hash
 
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#define MAX 15000000
using namespace std;

char str[MAX];
bool Hash[MAX];
int name[260];
int n,nc;

int main()
{
	while(scanf("%d%d%s",&n,&nc,str)!=EOF)
	{
		memset(name,0,sizeof(name));
		memset(Hash,false,sizeof(Hash));
		int len=strlen(str);
		
		int t=0;
		for(int i=0;i<len;i++)
			if(name[str[i]]==0)
				name[str[i]]=t++;  //将字符串中不同的字母赋为不同数字,存入name中

		t=nc;
		int tmp=0;
		for(int i=0;i<n-1;i++)
		{
			t*=nc;
			tmp=tmp*nc+name[str[i]]; //若将字符串按字母转化后构成的数字看作nc进制
		}			       //tmp则为前(n-1)位化为十进制的值

		int ans=0;
		for(int i=n-1;i<len;i++)
		{
			tmp=(tmp*nc+name[str[i]])%t;  //诸位向后求字符串对应数字化为十进制的值
			if(!Hash[tmp])		  //%t意为:求数字后n位的值
			{
				ans++;
				Hash[tmp]=true;
			}
		}

		printf("%d\n",ans);
	}
	return 0;
}

注:
%t 的解释:
若在十进制数1234中,试图求后两位,则:1234%(10^2)=34
同理,在nc进制数tmp中,试图求后n位,则:tmp%(nc^n)
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值