poj-1200 Crazy Search

1 篇文章 0 订阅
Language:
Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19424 Accepted: 5506

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

 
哈希表的简单运用,这里的hash思想是(以题目为例),题目中输入的4就代表该字符串共有4个不同的字符组成,然后问有多少个不同的字符长度为3的字符串,那么在搜的过程中就将每次搜索到的字符串进行数字化,并判断是否存在于hash数组(自己建立的一个数组足够大能够与不同字符串一一对应),该题的关键就是采用如何的数字化才使得不同字符串对应不同数组呢:
          最常见的就是例如此处是字符长度为3的字符串abc(分别对应123),那么数字化应该为:1*4*4+2*4+3;其中4为输入字符串的不同字符个数。
具体见如下代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define MAX 16000000
int being[MAX];
char s[MAX];
int ascii[256]={0}; 
int main(){
     int n,nc,i,t,sum=0,len=0,num=0,pow=1;
     long long result=0;
     scanf("%d %d",&n,&nc);
     memset(being,0,sizeof(being));
     memset(ascii,0,sizeof(ascii));
     scanf("%s",s);
     len=strlen(s);
     for(i=0;i<=len-1;i++)
        ascii[s[i]]=1;//将出现过的字符设置为1,表示存在 
     for(i=0;i<256;i++){
        if(ascii[i])//对字符进行从小到大排序 
           ascii[i]=num++;
     }
     for(i=0;i<=n-1;i++){
        sum=sum*nc;//乘以进位数 
        sum=sum+ascii[s[i]];//加上尾数 
     }
     being[sum]=1,result++;
     for(i=0;i<n-1;i++)
        pow*=nc;
     for(i=n;i<=len-1;i++){
        sum-=ascii[s[i-n]]*pow;
        sum=sum*nc+ascii[s[i]];
        if(being[sum]==0)
           result++,being[sum]=1;
     } 
     printf("%lld\n",result);
     return 0;              
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值