【POJ】1005 I Think I Need a Houseboat

Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.) 

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.


一道水题。

不要求每年被侵蚀的面积增加的半径,这个思路是错的。

每年增加的面积是固定的50,那么我只要求出以房子所在的点(x,y)到点(0,0)的距离为半径的半圆的面积,、

然后再除去每年增加的面积,向上取整,就得到侵蚀到房子的时候所需要的年份。

注意年份是从第1年开始,所以求出来的年数要+1


怒贴代码:

#include<stdio.h>
#include<iostream>

using namespace std;

int main()
{
    int n;
    const double pi=3.141592654;
    while(scanf("%d",&n)!=EOF)
    {
        double x,y,area;
        int year;
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&x,&y);
            area=pi*(x*x+y*y)/2;
            year=(int)(area/50.0+1.0);
            printf("Property %d: This property will begin eroding in year %d.\n",i,year);
        }
        printf("END OF OUTPUT.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值