Link: http://acm.hdu.edu.cn/showproblem.php?pid=2037
今年暑假不AC
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45038 Accepted Submission(s): 24139
Problem Description
“今年暑假不AC?”
“是的。”
“那你干什么呢?”
“看世界杯呀,笨蛋!”
“@#$%^&*%...”
确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视了。
作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)
Input
输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。
Output
对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。
Sample Input
12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0
Sample Output
5
Author
lcy
Source
ACM程序设计期末考试(2006/06/07)
Recommend
lcy | We have carefully selected several similar problems for you: 1050 1009 1051 1789 1257
解释
网上大多数讲的是简单贪心,其实我感觉这个题的最朴素的思想是DAG,每次选的节目都会对后面的节目选择加上限制,因此我们不妨从后往前看,每次看的这一个必然是选择这个之后的可选择的最大的一个,weight表示选择这个后还可以选的个数。这样便不会造成影响。
Code
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn(105);
int n;
struct node
{
int Ti_s,Ti_e;
int weight;
bool operator < (const node&a)const
{
if(this->Ti_s==a.Ti_s)
return this->Ti_e<a.Ti_e;
return this->Ti_s<a.Ti_s;
}
}program[maxn];
int main()
{
while(scanf("%d",&n),n)
{
for(int i=1;i<=n;i++)
{
scanf("%d%d",&program[i].Ti_s,&program[i].Ti_e);
program[i].weight=1;
}
sort(program+1,program+n+1);
int ans=1;
for(int i=n;i>=1;i--)
{
int res=0;
for(int j=i+1;j<=n;j++)
{
if(program[i].Ti_e<=program[j].Ti_s)
res=max(res,program[j].weight);
}
program[i].weight=res+1;
ans=max(ans,program[i].weight);
}
cout<<ans<<endl;
}
return 0;
}