poj-1338-Ugly Numbers-数论

Ugly Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22951 Accepted: 10204

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

解释

每一个数必然满足,另外要注意重复

Code

#include<cstdio>

#include<iostream>

#include<queue>

using namespace std;

const int maxn(1500);

long longugly_numbers[maxn];

priority_queue <longlong > state_ugly_numbers;

void init()

{

    ugly_numbers[0]=1;

    state_ugly_numbers.push(-2);

    state_ugly_numbers.push(-3);

    state_ugly_numbers.push(-5);

    long long now;

    for(int i=1;i<maxn;i++)

    {

        do

        {

            now=state_ugly_numbers.top();

            state_ugly_numbers.pop();

        }while(now==-ugly_numbers[i-1]);/****可能会出现重复*****/

        ugly_numbers[i]=-now;

        state_ugly_numbers.push(now*2);

        state_ugly_numbers.push(now*3);

        state_ugly_numbers.push(now*5);

    }

}

int main()

{

    init();

    int n;

    while(scanf("%d",&n),n)

    {

        cout<<ugly_numbers[n-1]<<endl;

    }

    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值