POJ 1195 Mobile phones( IOI 2001) 二维树状数组 CDQ分治 代码

Mobile phones

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 24928 Accepted: 11377

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.


The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

 

二维树状数组代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define MAXN 1025
int N,S[MAXN][MAXN];
void add(int x,int y,int value)
{
      for(int i=x;i<=N;i+=(i&(-i)))
            for(int j=y;j<=N;j+=(j&(-j)))
                  S[i][j]+=value;
}
int getsum(int x,int y)
{
      int tmp=0;
      for(int i=x;i>=1;i-=(i&(-i)))
            for(int j=y;j>=1;j-=(j&(-j)))
                  tmp+=S[i][j];
      return tmp; 
}
int main()
{
      //freopen("input.in","r",stdin);
      //freopen("output.out","w",stdout);
      int sign;
      while(scanf("%d",&sign)!=EOF)
      {
            if(sign==0)
            {   
                  scanf("%d",&N);
                  continue;
            }
            if(sign==1)
            {
                  int X,Y,V;
                  scanf("%d%d%d",&X,&Y,&V);
                  X++,Y++;
                  add(X,Y,V);
            }
            if(sign==2)
            {
                  int X1,Y1,X2,Y2;
                  scanf("%d%d%d%d",&X1,&Y1,&X2,&Y2);
                  X1++,Y1++,X2++,Y2++;
                  printf("%d\n",getsum(X1-1,Y1-1)-getsum(X1-1,Y2)+getsum(X2,Y2)-getsum(X2,Y1-1));             
            }
            if(sign==3)   break;
      }
      return 0;
}

CDQ分治代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define MAX 640001
#define MAXN 2000001
#define MAXQ 60001
struct ASK{int num,x,y,v,kind,in;}a[MAX],T[MAX];
int N,Q,tot=0,S[MAXN],ans[MAXQ];
void add(int x,int value)
{
     for(int i=x;i<=N;i+=(i&(-i)))S[i]+=value;
}
int getsum(int x){int tmp=0;for(int i=x;i>0;i-=(i&(-i)))tmp+=S[i];return tmp;};
bool cmp(ASK X,ASK Y){return X.x<Y.x;}
void addask(int num,int x,int y,int value,int kind)
{
      ++tot;
      a[tot].in=tot;
      a[tot].num=num;
      a[tot].x=x;
      a[tot].y=y;
      a[tot].v=value;
      a[tot].kind=kind;
}
void solve(int left,int right)
{
      if(left==right)   return;
      int middle=(left+right)/2,s1=left-1,s2=middle;
      for(int i=left;i<=right;i++)
      {
            if(a[i].in<=middle)
                 T[++s1]=a[i]; 
            else T[++s2]=a[i];
      }
      for(int i=left;i<=right;i++)
            a[i]=T[i];
      
      int now=left;
      for(int i=middle+1;i<=right;i++)
      {
            if(a[i].kind==2)
            {
                  while(a[now].x<=a[i].x && now<=middle)
                  {
                        if(a[now].kind==1)   add(a[now].y,a[now].v);
                        now++;
                  }
                  ans[a[i].num]+=a[i].v*getsum(a[i].y);
            }
      }
      now--;
      while(left<=now)
      {
            if(a[now].kind==1)
                  add(a[now].y,-a[now].v);
            now--;
      }
      solve(left,middle);
      solve(middle+1,right);
}
int main()
{
      //freopen("input.in","r",stdin);
      //freopen("output.out","w",stdout);
      int sign;
      while(scanf("%d",&sign)!=EOF)
      {
            if(sign==0)
            {   
                  if(tot)
                  {
                        sort(a+1,a+1+tot,cmp);
                        solve(1,tot);
                        for(int i=1;i<=Q;i++)
                              printf("%d\n",ans[i]);
                  }
                  scanf("%d",&N);
                  memset(ans,0,sizeof(ans));
                  memset(S,0,sizeof(S));
                  tot=0;Q=0;
                  continue;
            }
            if(sign==1)
            {
                  int X,Y,V;
                  scanf("%d%d%d",&X,&Y,&V);
                  X++,Y++;
                  addask(0,X,Y,V,1);
            }
            if(sign==2)
            {
                  int X1,Y1,X2,Y2;
                  scanf("%d%d%d%d",&X1,&Y1,&X2,&Y2);
                  X1++,Y1++,X2++,Y2++;Q++;
                  addask(Q,X1-1,Y1-1,1,2);  
                  addask(Q,X1-1,Y2,-1,2);
                  addask(Q,X2,Y2,1,2);
                  addask(Q,X2,Y1-1,-1,2);         
            }
            if(sign==3)   break;
      }
      sort(a+1,a+1+tot,cmp);
      solve(1,tot);
      for(int i=1;i<=Q;i++)
            printf("%d\n",ans[i]);
      return 0;
}

CDQ分治的详细分析可见:https://blog.csdn.net/csyzcyj/article/details/107298731

 

转载注明出处:https://blog.csdn.net/csyzcyj/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值