How Many Sets I


Description

Give a set S, |S| = n, then how many ordered set group (S1, S2, ..., Sk) satisfies S1 ∩ S2 ∩ ... ∩ Sk = ∅. (Si is a subset of S, (1 <= i <= k))

Input

The input contains multiple cases, each case have 2 integers in one line represent n and k(1 <= k <= n <= 231-1), proceed to the end of the file.

Output

Output the total number mod 1000000007.

Sample Input

1 1
2 2

Sample Output

1
9


注意本题有序,就当做是序偶就行了!!从而推导公式ans=(2^k-1)^n

代码:

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <queue>
#include <cstdio>
#include <cmath>
#include <string>
#include <stack>
#include <cctype>
using namespace std;
#define mod 1000000007
long long fun(long long a,long long p,long long m)
{
    if(p==0)
        return 1;
    long long r=a%m;
    long long k=1;
    while(p>1)
    {
        if((p&1)!=0)
        {
            k=(k*r)%m;
        }
        r=(r*r)%m;
        p>>=1;
    }
    return (r*k)%m;
}


int main()
{
    long long n,k;
    while(cin>>n>>k)
    {
        long long sum;
        sum=fun(2,k,mod)-1;
        long long temp;
        temp=fun(sum,n,mod);
        cout<<temp<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值