ZOJ 3556 How Many Sets I

How Many Sets I

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Give a set S, |S| = n, then how many ordered set group (S1, S2, ..., Sk) satisfies S1 ∩ S2 ∩ ... ∩ Sk = ∅. (Si is a subset of S, (1 <= i <= k))

Input

The input contains multiple cases, each case have 2 integers in one line represent n and k(1 <= k <= n <= 231-1), proceed to the end of the file.

Output

Output the total number mod 1000000007.

Sample Input
1 1
2 2
Sample Output
1
9

题意:

个数为n的集合,从中选出K个子集使得他们的交集为空的个数。

  子集可以重复选


考虑1个元素
它在k子集里的数目为2^k
其中有一种是k个子集都有这个元素,他们这k个子集的交集就不为空
所以1个元素k个子集交集为空的数目 有(2^k)-1 种
那么n个元素就是((2^k)-1)^n


#include<cstdio>
using namespace std;
typedef long long LL;
const LL mod=1000000007;
LL n,k;
LL pow(LL a,LL b)
{
    LL r=1;
    while(b)
    {
        if(b&1) r*=a,r%=mod;
        b>>=1; a*=a; a%=mod;
    }
    return r;
}
int main()
{
    while(scanf("%lld%lld",&n,&k)!=EOF) 
    printf("%lld\n",pow(pow(2,k)-1,n));
}

 


转载于:https://www.cnblogs.com/TheRoadToTheGold/p/7356303.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值