ZOJ 3556 How Many Sets I 解题报告(数论)

96 篇文章 0 订阅

How Many Sets I

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Give a set S, |S| = n, then how many ordered set group (S1, S2, ..., Sk) satisfies S1 ∩ S2 ∩ ... ∩ Sk = ∅. (Si is a subset of S, (1 <= i <= k))

Input

The input contains multiple cases, each case have 2 integers in one line represent n and k(1 <= k <= n <= 231-1), proceed to the end of the file.

Output

Output the total number mod 1000000007.

Sample Input
1 1
2 2
Sample Output
1
9

Author:  QU, Zhe
Contest:  ZOJ Monthly, October 2011

    解题报告: 求无交集的子集数,即总情况数减去有交集的子集数。

    易知,2^n^k - C(n, 1)*2^(n-1)^k + C(n, 2)*2^(n-2)^k ... C(n, n)*2^(n-n)^k 即为答案。可化简为(2^k - 1)^n。

    两次快速幂,即为解。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long LL;
const int mod = 1000000007;

int powMod(LL a,int b)
{
    LL res=1;
    while(b)
    {
        if(b&1)
            res = (res*a)%mod;
        b >>= 1;
        a = (a*a)%mod;
    }
    return res;
}

int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
        printf("%d\n", powMod((powMod(2, k)-1+mod)%mod, n));
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值