UVA10785 - The Mad Numerologist

题目链接:UVA10785 - The Mad Numerologist


 The Mad Numerologist 

Numerology is a science that is used by many people to find out a mans personality, sole purpose of life, desires to experience etc. Some calculations of numerology are very complex, while others are quite simple. You can sit alone at home and do these easy calculations without taking any ones help. However in this problem you wont be asked to find the value of your name.
\epsfbox{p10785a.eps}
To find the value of a name modern numerologists have assigned values to all the letters of English Alphabet. The table on the left shows the numerical values of all letters of English alphabets. Five letters A, E, I, O, U are vowels. Rests of the letters are consonant. In this table all letters in column 1 have value 1, all letters in column 2 have value 2 and so on. So T has value 2, F has value 6, R has value 9, O has value 6 etc. When calculating the value of a particular name the consonants and vowels are calculated separately. The following picture explains this method using the name ``CHRISTOPHER RORY PAGE".
\epsfbox{p10785b.eps}
So you can see that to find the consonant value, the values of individual consonants are added and to find the vowel value the values of individual vowels are added. A mad Numerologist suggests people many strange lucky names. He follows the rules stated below while giving lucky names.
  • The name has a predefined length N.
  • The vowel value and consonant value of the name must be kept minimum.
  • To make the pronunciation of the name possible vowels and consonants are placed in alternate positions. Actually vowels are put in odd positions and consonants are put in even positions. The leftmost letter of a name has position 1; the position right to it is position 2 and so on.
  • No consonants can be used in a name more than five times and no vowels can be used in a name more than twenty-one times
  • Following the rules and limitations above the name must be kept lexicographically smallest. Please note that the numerologists first priority is to keep the vowel and consonant value minimum and then to make the name lexicographically smallest.

Input 

First line of the input file contains an integer  N  (   0 < N$ \le$250 ) that indicates how many sets of inputs are there. Each of the next  N lines contains a single set of input. The description of each set is given below: Each line contains an integer  n  (   0 < n < 211 ) that indicates the predefined length of the name.

Output 

For each set of input produce one line of output. This line contains the serial of output followed by the name that the numerologist would suggest following the rules above. All letters in the output should be uppercase English letters.

Sample Input 

3
1
5
5

Sample Output 

Case 1: A
Case 2: AJAJA
Case 3: AJAJA

题意

每个字母都有其价值

一个名字的元音价值是其元音字母的价值和,辅音价值是起辅音字母的价值和

这个名字有一个固定的长度N

先保证元音字母的价值和辅音字母的价值要最小,再保证名字要在字典序里面最小

第一个字符表示为1,元音字母在奇数位置,辅音在偶数位置

同一辅音最多出现5次,元音21次

分析

价值最小,首先得选取单个价值越小越好的,然后将其全部用完,再来考虑其他的字母。

字典序最小,那么就要对选取的字母进行较好的排序才能实现。

因此,首先需要做的是选字母,那些字母需要被选进来,以及需要的个数。

然后,按照字典序排列,将在字典序里面越前面的字母越早全部输出,再去排列其他的字母,注意元音与辅音的交叉排列。

代码

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct charc
{
    char x;
    int num;
};

bool cmp(charc a, charc b)
{
    return a.x < b.x;
}
int main()
{
    char vowels[] = "0AUEOI";
    char cons[] = "0JSBKTCLDMVNWFXGPYHQZR";
    int numv[7], numc[23];
    int t, n, cas = 1;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);

        int vow = n/2;
        if(n%2 != 0) vow++; //num of vowels
        int cv = vow/21;
        for(int i = 1; i <= cv; i++)
            numv[i] = 21;
        if(vow%21 != 0)
        {
            cv++;
            numv[cv] = vow%21;
        }
        charc VW[7], CNN[24];
        for(int i = 1; i <= cv; i++)
        {
            VW[i].x = vowels[i];
            VW[i].num = numv[i];
        }
        int con = n/2;  //num of cons
        int cn = con/5;
        for(int i = 1; i <= cn; i++)
            numc[i] = 5;
        if(con%5 != 0)
        {
            cn++;
            numc[cn] = con%5;
        }
        for(int i = 1; i <= cn; i++)
        {
            CNN[i].x = cons[i];
            CNN[i].num = numc[i];
        }
        sort(VW+1, VW+cv+1, cmp);
        sort(CNN+1, CNN+cn+1, cmp);
        int cnt1 = 0;
        char ans1[150], ans2[150];
        for(int i = 1; i <= cv; i++)
            for(int j = 1; j <= VW[i].num; j++)
                ans1[cnt1++] = VW[i].x;
        int cnt2 = 0;
        for(int i = 1; i <= cn; i++)
            for(int j = 1; j <= CNN[i].num; j++)
                ans2[cnt2++] = CNN[i].x;
        cnt1 = cnt2 = 0;
        printf("Case %d: ", cas++);
        for(int i = 1; i <= n; i++)
        {
            if(i%2!=0)
                printf("%c", ans1[cnt1++]);
            else
                printf("%c", ans2[cnt2++]);
        }
        printf("\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值