HDU 1003 Max Sum

11 篇文章 0 订阅

题目链接:HDU 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 142614    Accepted Submission(s): 33181


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1087  1069  1058  1159  1203 
 

题意

    经典最大子段和问题,求一个子序列,是的它的和是所有子序列中最大的,输出起始位置了结束位置。

分析

    动态规划思想,dp[i]表示以i结尾的从第1个到第i个中的最大子段和。

    当要将第i个元素考虑进来的时候,如果dp[i-1]小于0,即从第一个到第i个元素的最大子段和小于0,那么加上后面的a[i]甚至还减少了dp[i]的值,这样是不可取的,那么就应该以i为起始点重新开始计算子段和,如果dp[i-1]>0,则加上后面的a[i]可以表示到i的最大子段和,它是比a[i]大的。

    转移方程:dp[i] = max(dp[i-1], 0)+a[i],注意记录起始点。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int t, n, a[100010], dp[100010], f[100010];
    scanf("%d", &t);
    int cas = 1;
    while(t--)
    {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            f[i] = 1;
        }
        dp[0] = -99999999;
        int maxs = -9999999, index = 1;
        for(int i = 1; i <= n; i++)
        {
            if(dp[i-1] >= 0)
            {
                dp[i] = dp[i-1]+a[i];
                f[i] = f[i-1];
            }
            else
            {
                dp[i] = a[i];
                f[i] = i;
            }
            if(maxs < dp[i])
            {
                maxs = dp[i];
                index = i;
            }
        }
        printf("Case %d:\n%d %d %d\n", cas++, dp[index], f[index], index);
        if(t != 0)
            printf("\n");
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值