HDU 1018 Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19


题目大意:求n!的位数

方法1:一个数n的位数可以用1+log10(n)求得

                 代码如下:

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;

int main()
{
    int t,n,i;
    double sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        sum=1;
        for(i=1;i<=n;i++)
            sum+=log10(i);
        cout<<(int)sum<<endl;

    }
    return 0;
}

Pro.IDExe.TimeExe.MemoryCode Len.Language
 1018984MS340K328 BG++ 

方法2:斯特林公式

#include <iostream>
#include <cmath>
using namespace std;
#define PI 3.14159265
int main()
{
    int n,t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        cout<<(int)((0.5*log(PI*2*n)+n*log(n)-n)/log(10))+1<<endl;
    }
    return 0;
}

Judge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
Accepted10180MS344K259 BG++Array

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值