04-树5 Root of AVL Tree

这篇博客介绍了AVL树作为自平衡二叉搜索树的概念,强调了树中任意节点两个子树高度差最多为1的特性。当这个平衡条件被破坏时,需要通过旋转规则进行重平衡。输入规格说明了每个测试用例包含一个正整数N(≤20),表示要插入的键的数量,接下来的一行给出N个不同的整数键。输出规格要求打印出构建的AVL树的根节点。
摘要由CSDN通过智能技术生成
04-树5 Root of AVL Tree   (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88


思路:

基础题,建一个AVL树


#include <iostream>

using namespace std;

typedef struct TNode* AVLTree;
struct TNode
{
    int height;
    AVLTree left;
    AVLTree right;
    int data;
};
int Max(int x,int y)
{
    int q;
    x>y?q=x:q=y;
    return q;
}
int Height(AVLTree t)
{
    if(t == NULL)
        return -1;
    else
        return t->height;
}
AVLTree SingleRotateWithLeft(AVLTree T) //LL
{
    AVLTree k;
    k = T->left;
    T->left = k->right;
    k->right = T;
    k->height = Max(Height(k->left), Height(k->right)) + 1;
    T->height = Max(Height(T->left), Height(T->right)) + 1;
    return k;
}
AVLTree SingleRotateWithRight(AVLTree T) //RR
{
    AVLTree k;
    k = T->right;
    T->right = k->left;
    k->left = T;
    k->height = Max(Height(k->left), Height(k->right)) + 1;
    T->height = Max(Height(T->left), Height(T->right)) + 1;
    return k;
}
AVLTree DoubleRotateWithLeft(AVLTree T) //LR
{
    T->left = SingleRotateWithRight(T->left);
    T = SingleRotateWithLeft(T);
    return T;
}
AVLTree DoubleRotateWithRight(AVLTree T) //RL
{
    T->right = SingleRotateWithLeft(T->right);
    T = SingleRotateWithRight(T);
    return T;
}
AVLTree Insert(AVLTree T, int x)
{
    if(T == NULL)
    {
        T = new TNode;
        T->left = T->right = NULL;
        T->data = x;
    }
    else if(x < T->data)  //left child
    {
        T->left = Insert(T->left, x);
        if(Height(T->left) - Height(T->right) == 2)
        {
            if(x < T->left->data)
                T = SingleRotateWithLeft(T);//LL
            else if(x > T->left->data)
                T = DoubleRotateWithLeft(T);//LR
        }
    }
    else if(x > T->data)  //right child
    {
        T->right = Insert(T->right, x);
        if(Height(T->right) - Height(T->left) == 2)
        {
            if(x > T->right->data)
                T = SingleRotateWithRight(T);//RR
            else if(x < T->right->data)
                T = DoubleRotateWithRight(T);//RL
        }
    }

    //update T's height
    T->height = Max(Height(T->left), Height(T->right)) + 1;
    return T;
}
int main()
{
    int n,x;
    AVLTree T = NULL;
    cin>>n;
    for(int i=0; i<n; i++)
    {
        cin>>x;
        T = Insert(T,x);
    }
    cout << T->data << endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值