Poj3984 迷宫问题

题目:
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:BFS,加记录反向路径。
居然调试了半天,我发现我写代码已经很久没用二维数组了。

#include <iostream>
#include <queue>
using namespace std;

static int record[5][5];
static bool visited[5][5];
typedef pair<int, int> Point;
int main()
{
    //int input[5][5] = {
    //  0, 1, 0, 0, 0,

    //  0, 1, 0, 1, 0,

    //  0, 0, 0, 0, 0,

    //  0, 1, 1, 1, 0,

    //  0, 0, 0, 1, 0,
    //};

    record[0][0] = -1;
    visited[0][0] = true;
    int input[5][5];
    for (int i = 0;i < 5;i++)
    {
        for (int j = 0;j < 5;j++)
            cin >> input[i][j];
    }
    queue<Point> q;
    q.push(Point(0,0));

    while (!q.empty())
    {
        Point target = q.front();
        q.pop();
        int x = target.first;
        int y = target.second;

        if (x == 4 && y == 4)
            break;
        int nx, ny;
        // top
        nx = x - 1, ny = y;
        if (nx > 0 && input[nx][ny] != 1 && !visited[nx][ny])
        {
            q.push(Point(nx, ny));
            record[nx][ny] = 5 * x + y + 1;
            visited[nx][ny] = true;
        }
        // bottom
        nx = x + 1, ny = y;
        if (nx < 5 && input[nx][ny] != 1 && !visited[nx][ny])
        {
            q.push(Point(nx, ny));
            record[nx][ny] = 5 * x + y + 1;
            visited[nx][ny] = true;
        }
        // left
        nx = x, ny = y - 1;
        if (ny > 0 && input[nx][ny] != 1 && !visited[nx][ny])
        {
            q.push(Point(nx, ny));
            record[nx][ny] = 5 * x + y + 1;
            visited[nx][ny] = true;
        }
        // right
        nx = x, ny = y + 1;
        if (ny < 5 && input[nx][ny] != 1 && !visited[nx][ny])
        {
            q.push(Point(nx, ny));
            record[nx][ny] = 5 * x + y + 1;
            visited[nx][ny] = true;
        }

    }
    vector<Point> vec;
    int tx = 4, ty = 4;
    while (record[tx][ty] != -1)
    {
        vec.push_back(Point(tx, ty));
        int v = record[tx][ty];
        tx = (v - 1) / 5;
        ty = v - tx * 5 - 1;
    }
    cout << "(" << 0 << ", " << 0 << ")" << endl;
    for (int i = vec.size() - 1;i >= 0;i--)
    {
        cout << "(" << vec[i].first << ", " << vec[i].second << ")" << endl;
    }

    return 1;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值