poj3984迷宫问题 广搜+最短路径+模拟队列

Description
定义一个二维数组:
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
 
参考代码:
#include<iostream>
using namespace std;
int map[5][5];
int vis[5][5];
struct node{
	int x;
	int y;
	int pre;
}edge[100];
int front=0,rear=1;//队头,队尾
int dir[4][2]={{0,-1},{1,0},{0,1},{-1,0}};
void f(int i)//倒向追踪法
{
	if(edge[i].pre!=-1)
	{
		f(edge[i].pre);
		cout<<"("<<edge[i].x<<", "<<edge[i].y<<")"<<endl;
	}
}
void BFS(int x,int y)
{
	edge[front].x=x;
	edge[front].y=y;
	edge[front].pre=-1;
	while(front<rear)//队列为空时终止
	{
		int u;
		for(u=0;u<4;u++)
		{
			int x=edge[front].x+dir[u][0];
			int y=edge[front].y+dir[u][1];
			if(x<0||x>=5||y<0||y>=5||vis[x][y]==1||map[x][y]==1)
				continue;
			else
			{
				vis[x][y]=1;
				map[x][y]=1;
				edge[rear].x=x;//入队
				edge[rear].y=y;
				edge[rear].pre=front;
				rear++;
			}
			if(x==4&&y==4)
				f(front);
		}
		front++;//出队
	}
}
int main()
{
	int i,j;
	for(i=0;i<5;i++)
	{
		for(j=0;j<5;j++)
		{
			cin>>map[i][j];
		}
	}
	memset(vis,0,sizeof(vis));
	cout<<"("<<"0, 0)"<<endl;
	BFS(0,0);
	cout<<"(4, 4)"<<endl;
	return 0;
}





 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值