hdu2577 特殊动归 How to Type

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3344    Accepted Submission(s): 1548


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

Author
Dellenge
 
这个题比较有意思。大意是一个人要打一些字,他有两种方法,一种是Shift+字母,一种是Capslock之后打字母,这两种可以灵活应用,问打一段单词最少的按键次数。。
用dp[i][1]表示完成i打印Cap灯亮最小的步数,dp[i][0]表示完成i打印Cap灯灭的最小的步数,那么状态转移的时候dp[i][?]只能从dp[i-1][?]中转移,而且选小的,这样就好办了。
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[105][2];   //dp[i][1]表示完成i打印Cap灯亮,dp[i][0]表示完成i打印Cap灯灭时的最小敲键盘数
char str[110];
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>str+1;
		int i,j=strlen(str+1);
		dp[0][0]=0;
		dp[0][1]=1;
		 //刚开始Caps Lock为关闭状态
		for(i=1;i<=strlen(str+1);++i)
		{
			if(str[i]>='A'&&str[i]<='Z')
			{//若灯亮,则直接按字母;若灯灭,则开灯再按字母
				dp[i][1]=min(dp[i-1][1]+1,dp[i-1][0]+2);
				dp[i][0]=min(dp[i-1][1]+2,dp[i-1][0]+2);
			}//若灯亮,则要先按字母再关灯;若灯灭,则按shift+字母  
			else
			{//若灯亮,则按shift+字母 ;//若灯灭,则要先按字母再开灯;
				dp[i][1]=min(dp[i-1][1]+2,dp[i-1][0]+2);
				dp[i][0]=min(dp[i-1][1]+2,dp[i-1][0]+1);
			}//若灯亮,则先关灯再按字母 ;//若灯灭,则直接按字母;
		}
		int ans=min(dp[j][0],dp[j][1]+1);
		cout<<ans<<endl;
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值