hdu1160 FatMouse's Speed 最长下降子序列 及其打印

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8713    Accepted Submission(s): 3870
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7
 
/*
给出n个老鼠的重量和速度值(先重量后速度),
要求给出一个最长的排列,其中,前一只老鼠的
重量严格小于后一只老鼠,而它的速度要严格大于
后一只老鼠。给出的排列可能与示例不同,因为排
列可能有多种,只要求出一种就可以了。
*/
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1010],b[1010];// 记录前驱
struct mice
{
	int w;
	int s;
	int pos;
};
mice m[1010];//此比较函数让数据按照w递增,同时w相同时按照s递曾排列
bool cmp(mice a,mice b)
{
	if(a.w!=b.w)
	{	
		if(a.w<b.w)
			return true;
		else
			return false;
	}
	else if(a.w==b.w)
	{
		if(a.s<b.s)
			return true;
		else
			return false;
	}
		
}

void print_ans(int x)  //打印输出
{  
    int y = b[x];  
    if(y == -1)  
    {  
        cout<< m[x].pos<<endl;  
        return ;  
    }  
    print_ans(y);  
    cout<<m[x].pos<<endl;  
}  
int main()
{
	int n=0,index=0;
	while(cin>>m[n].w>>m[n].s)
	{
		m[n].pos=n+1;
		n++;
	}
	sort(m,m+n,cmp);
	//for(int i=0;i<n;++i)
	//	cout<<m[i].w<<" "<<m[i].s<<" "<<m[i].pos<<endl;
	//cout<<endl;
	int i,j,Max=0;
	for(i=0;i<n;++i)  
	{  
		dp[i]=1; 
		b[i]=-1;
		for(j=0;j<i;++j)  
		{  
			if(m[j].s>m[i].s&&dp[j]+1>dp[i])
			{
				dp[i]=dp[j]+1;  
				b[i]=j;
			}
		}  
		if(dp[i]>Max)  
		{
			Max=dp[i]; 
			index=i;
			
		}
	}  
	cout<<Max<<endl; 
	print_ans(index);
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值