hdu1160 FatMouse's Speed (求最长严格下降子序列路径)

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12507    Accepted Submission(s): 5489
Special Judge

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1024  1074  1114  1159  1025 
 

解析:子序列要满足:weight递增,但是speed递减,并且有可能多只老鼠的weight相同。

           我这里是是一个O(n^2)的解法,具体思路就不说了,直接看代码吧。

代码:

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=1e3;
int last[maxn+10],len[maxn+10];
struct tnode{
	int d,weight,speed;
}p[maxn+10];

bool cmp(tnode a,tnode b)
{
  return a.weight>b.weight;
}

int main()
{
  //freopen("1.in","r",stdin);
  
  int n=1,i,j,k;
  while(scanf("%d%d",&p[n].weight,&p[n].speed)!=EOF)n++;
  len[0]=0,last[1]=0;
  for(i=1;i<n;i++)p[i].d=i,len[i]=1;
  sort(p,p+n,cmp);
  for(i=2;i<n;i++)
    {
	  for(k=0,j=1;j<i;j++)
	    if(p[j].weight>p[i].weight && 
		   p[j].speed<p[i].speed && 
		   len[j]>len[k])k=j;
	  last[i]=k,len[i]=len[k]+1;
    }
  for(k=1,i=2;i<n;i++)if(len[i]>len[k])k=i;
  printf("%d\n",len[k]);
  while(k)printf("%d\n",p[k].d),k=last[k];
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值