HDU 1160 FatMouse's Speed 最长上升子序列

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17077    Accepted Submission(s): 7556
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1024  1074  1025  1081  2059 
 


最长上升子序列,输出路径比较麻烦,看了看他们网上的代码,就是价格数组,最后递归或者用栈输出一下

ac代码:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <stack>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;

struct node{
	int w,s;
	int index; 
}nn[1005];
int dp[1005];
int path[1005];
bool cmp(node a,node b){
	if(a.w ==  b.w)
		return a.s > b.s;
	
	return a.w < b.w;
}

int main(){
	
	int cnt=1;
	while(~scanf("%d%d",&nn[cnt].w,&nn[cnt].s)){
		nn[cnt].index=cnt;
		cnt++;
	}
	sort(nn+1,nn+cnt,cmp);
	int mmax=-1;
	int index=0;
	for(int i=0;i<=cnt;i++){
		path[i]=i;
	}
	for(int i=1;i<cnt;i++){
		dp[i]=1;
		for(int j=1;j<i;j++){
			if(nn[i].w > nn[j].w && nn[i].s < nn[j].s && dp[i]<dp[j]+1){
				dp[i]=dp[j]+1;
				path[i]=j;
				if(dp[i] > mmax){
					mmax=dp[i];
					index=i;
				}
				
			}
		}
	}
	printf("%d\n",mmax);
	stack <int> st;
	
	while(path[index]!=index){
		st.push(nn[index].index);
		index=path[index];
	}
	st.push(nn[index].index);
	while(!st.empty()){
		printf("%d\n",st.top());
		st.pop();
	}
	
	return 0;
}






  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值