hdu ——1242——Rescue

12 篇文章 0 订阅
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 
#include<iostream>
#include<queue>
using namespace std;
#define max 201
int n,m,f,res,ans[max][max];
char map[max][max];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
struct node
{
 int x,y;
 int time;
};
void bfs(int xr,int yr)
{
   queue<node> Q;
 node a,b;
 a.x=xr;
 a.y=yr;
 a.time=0;
 Q.push(a);
 while(!Q.empty())
 {
  int i,xx,yy;
  b=Q.front();
  Q.pop();
  for(i=0;i<4;i++)
  {
     xx=b.x+dir[i][0];
     yy=b.y+dir[i][1];
     a.x=xx;
     a.y=yy;
     if(a.x>0 && a.x<=n && a.y>0 && a.y<=m &&map[a.x][a.y]!='#')
     {
      if(map[a.x][a.y]=='.')
      {
       a.time=b.time+1;
      }
      else if(map[a.x][a.y]=='x')
      {
       a.time=b.time+2;
      }
      if(a.time<ans[a.x][a.y])    //判断当前到该点的时间是否小于先前搜索到该点的时间,如果更下则进队列,否则就不进
      {
       ans[a.x][a.y]=a.time;
       Q.push(a);
      }
      if(map[a.x][a.y]=='r'&& b.time+1<res )//遇到一次能救天使的人 判断当前的时间是否小于先前找到能救她的人的时间少
      {
       f=1;                               //并且保存小的时间
       res=b.time+1;
      }
     }
  }
 }
}
int main()
{
 int i,j,x,y;
// freopen("E:\\test.txt","r",stdin);
 while(cin>>n>>m)
 {
  for(i=1;i<=n;i++)
  {
   for(j=1;j<=m;j++)
   {
    cin>>map[i][j];
    ans[i][j]=999999;          //初始化每个搜索到每个点的时间为最大值
    if(map[i][j]=='a')
    {
       x=i;
       y=j;
    }
   }
  }
  f=0;
  res=999999;
  bfs(x,y);
  if(f==0)        // f用于标记是否可以找到一个能救天使的朋友
  {
   cout<<"Poor ANGEL has to stay in the prison all his life." <<endl;
  }
  else
  {
   cout<<res<<endl;
  }
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值