BFS - Rescue ZOJ - 1649


Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)


Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.



Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."



Sample Input

7 8 
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........


Sample Output

13



题意:r代表初始位置,a代表最终位置,#代表墙,遇到x则需要2个回合,正常走 . 则一个回合,问从初始位置到最终位置的最小回合数。

思路:乍一看好像也是用队列进行BFS的题,其实仔细想想则不对,遇到x时原本要2回合。但是此时它在队列的位置没有变动,则最终走出来的回合数会变多,要求最短则需考虑优先队列,那些用的步数较少的方案优先出列。

#include <cstdio>
#include <queue>
const int N = 300;
using namespace std;
int m,n;
char map[N][N]; //构建地图
struct Node
{
    int x,y;
    int step;
    friend bool operator<(Node n1,Node n2)  //定义用时短的优先出列(此处step理解为回合数)
    {
        return n1.step>n2.step;
    }
};
int dx[4]={0,0,1,-1};   //构建移动方向
int dy[4]={1,-1,0,0};   //构建移动方向
int Bfs(int sta,int stb,int ena,int enb)
{
    priority_queue<Node> q; //优先队列
    Node tmd,tmp;
    tmd.x=sta,tmd.y=stb,tmd.step=0;
    q.push(tmd);
    while(!q.empty())
    {
        tmd=q.top();q.pop();    //初始片段搜索结束条件的地方
        if(tmd.x==ena&&tmd.y==enb)
            return tmd.step;
        for(int i=0;i<4;i++)   //生成下一节点
        {
            tmp.x=tmd.x+dx[i];
            tmp.y=tmd.y+dy[i];
            if(map[tmp.x][tmp.y]=='x')
                tmp.step=tmd.step+2;
            else
                tmp.step=tmd.step+1;
            if(map[tmp.x][tmp.y]!='#'&&tmp.x>=0 &&tmp.y>=0 &&tmp.x<m&&tmp.y<n) //满足条件进入下一步
            { 
                q.push(tmp);
                map[tmp.x][tmp.y]='#';   //走过则变为墙,变相的做了标记,不走重复路
            }
        }
    }
    return -1;
}
int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        int sta,stb,ena,enb;
        getchar();   //输入后会留下\n,记得消去
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf(" %c",&map[i][j]);
                if(map[i][j]=='a')
                {
                    sta=i,stb=j;   //记录初始位置
                }
                if(map[i][j]=='r')
                {
                    ena=i,enb=j;   //记录最终位置
                }
            }
            //getchar();
        }
        int ans=Bfs(sta,stb,ena,enb);
        if(ans==-1)   //到不了最终地点
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",ans);

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值