poj——3159——Candies(spfa)

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:给n个人派糖果,给出m组数据,每组数据包含A,B,c  三个数,意思是A的糖果数比B少的个数不多于c,即B的糖果数 - A的糖果数<= c 。最后求n 比 1 最多多多少糖果。

#include <iostream>
#include <cstring>
#include <stack>
#include <cstdio>
#include <algorithm>
using namespace std;
const int M=350000;
const int inf=9999999;
int n,m;
int dist[M],vis[M],head[M];
int len;
struct node
{
    int to;
    int v;
    int next;
}Node[M];
void add(int from,int to,int v)
{
    Node[len].to=to;
    Node[len].v=v;
    Node[len].next=head[from];
    head[from]=len++;
}
void spfa()
{
    stack<int>q;
    int s=1;
    q.push(s);
    vis[s]=1;
    dist[s]=0;
    while(!q.empty())
    {
        int ans=q.top();
        q.pop();
        vis[ans]=0;
        for(int k=head[ans];k!=-1;k=Node[k].next)
        {
            int id=Node[k].to;
            if(dist[id]>dist[ans]+Node[k].v)
            {
                dist[id]=dist[ans]+Node[k].v;
                if(!vis[id])
                {
                    q.push(id);
                    vis[id]=1;
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        len=0;
        for(int i=1;i<=n;i++)
        {
            head[i]=-1;
            dist[i]=inf;
            vis[i]=0;
        }
        for(int i=0;i<m;i++)
        {
            int from,to,v;
            scanf("%d%d%d",&from,&to,&v);
            add(from,to,v);
        }
        spfa();
        printf("%d\n",dist[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值