I - Candies POJ - 3159 (数组模拟邻接表+栈优化spfa)

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and cin order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:分糖果,给出m条信息,每条信息的内容都是b的糖果数量最多不能比a多c,即b - a <= c。然后让求第n个同学最多比第一个同学多多少个糖果。

思路:给出的m条信息就是m条边,可以以给出的每条边的最大差值,即c为边上权值建图,最后来一发最短路径就好了,建议用spfa,然后用(stack)栈优化(队列优化会超时)!!!!

因为数据较大,所以要用邻接表,其次直接用链表建立邻接表是不行的,还得用数组模拟邻接表,这样的话才不会超时。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const int N = 50002;
int n, m, top;
int head[N], dist[N], vis[N];
struct node{
    int v, w;
    int next;
}edge[N * 3];

void add(int u, int v, int w)
{
    edge[top].v = v;
    edge[top].w = w;
    edge[top].next = head[u];
    head[u] = top++;
}

void spfa()
{
    for(int i = 1; i <= n; i++)
    {
        dist[i] = INF;
        vis[i] = 0;
    }
    dist[1] = 0;
    vis[1] = 1;
    stack < int > q;
    q.push(1);
    int ans;
    while(!q.empty())
    {
        ans = q.top();
        q.pop();
        vis[ans] = 0;
        for(int i = head[ans]; i != -1; i = edge[i].next)
        {
            if(dist[edge[i].v] > dist[ans] + edge[i].w)
            {
                dist[edge[i].v] = dist[ans] + edge[i].w;
                if(!vis[edge[i].v])
                {
                    q.push(edge[i].v);
                    vis[edge[i].v] = 1;
                }
            }
        }
    }
}

int main()
{
    //freopen("in.txt", "r", stdin);
    cin >> n >> m;
    top = 0;
    for(int i = 1; i <= n; i++)
    {
        head[i] = -1;
    }
    for(int i = 1; i <= m; i++)
    {
        int a, b, c;
        scanf("%d%d%d", &a, &b, &c);
        add(a, b, c);
    }
    spfa();
    cout << dist[n] << endl;
    return 0;
}

没想到还能用stack优化spfa,学到了。。。。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值