poj 2891 Strange Way to Express Integers 扩展欧几里得运用

Strange Way to Express Integers
Time Limit: 1000MSMemory Limit: 131072K
Total Submissions: 8468Accepted: 2552

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

 

 

 

这个题意的意思是说,要求求出一个最小的数据来为m,m%8==7,而且m%11==9,那么这个数据又该怎么去求呢??

k1*a1+b1=k2*a2+b2; 也就是k1*a1-k2*a2=b2-b1 ,当我们要求出k1时,这时我们也就可以求出来m了,还有一个不断

传递的问题,最后让 b1=k1*a1+b1, a1=a1*(a2/m), 就可以是实现逐层传递,还有求出k1的最小非负整数,这主要一

个区间的问题,用到了poj 1061的相关知识,是可以直接套用的,我做这个题目时直接就是在poj的代码上稍加修改就

AC了,嘿嘿。

 

#include<iostream>
#include<cstdio>
using namespace std;
long long exgcd(long long a, long long b, long long &x, long long &y)
{
    long long d, t;
    if (b == 0) { x = 1; y = 0; return a; }
    d = exgcd(b, a % b, x, y);
    t = x - a/b*y; x = y; y = t;
    return d;
}
int main()
{
    long long a1,a2,r1,r2;
    long long a,b,c,x,y;
    int k;
    int i;
    while(scanf("%d",&k)!=EOF)
    {

        scanf("%lld%lld",&a1,&r1);
        int flag=1;
        for(i=1;i<k;i++)
        {
            scanf("%lld%lld",&a2,&r2);
            a=a1;
            b=a2;
            c=r2-r1;
            long long m=exgcd(a,b,x,y);
            if(c%m)
            {
                flag=0;
            }
            long long s=b/m;
            x=x*(c/m);
            x=(x%s+s)%s;
            r1=x*a1+r1;
            a1=a1*(a2/m);
        }
        if(flag)
        {
            cout<<r1<<endl;

        }
        else
        {
            cout<<"-1"<<endl;
        }
    }

    return 0;


}


 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值