nbut [1220] SPY

  • [1220] SPY

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述
  • The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’sconfidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?

    A:the list contains that will come to the NationX’s frontier.

    B:the list contains spies that will be sent by Nation Y.

    C:the list contains spies that were sent to NationY before.

  • 输入
  • There are several test cases.
    Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.
    The second part contains A strings, the name list of that will come into the frontier.
    The second part contains B strings, the name list of that are sent by NationY.
    The second part contains C strings, the name list of the “dual_spy”.
    There will be a blank line after each test case.
    There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.
  • 输出
  • Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.
  • 样例输入
  • 8 4 3
    Zhao Qian Sun Li Zhou Wu Zheng Wang
    Zhao Qian Sun Li
    Zhao Zhou Zheng
    2 2 2
    Zhao Qian
    Zhao Qian
    Zhao Qian
    
  • 样例输出
  • Qian Sun Li
    No enemy spy
  • 提示
  • 来源
  • 辽宁省赛2010
  • 操作

这个题目真是算很水的,但是vector的做法确实很精妙,学习一下

 

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
bool contains(vector<string>v,string w)
{
    for(int i=0; i<v.size(); i++)
    {
        if(v[i]==w)
            return true;
    }
    return false;
}
int main()
{
    int m,n,k;
    string w;
    vector<string>v1,v2,v3,vcatch;
    while(scanf("%d%d%d",&m,&n,&k)!=EOF)
    {
        v1.clear();
        v2.clear();
        v3.clear();
        vcatch.clear();
        for(int i=0; i<m; i++)
        {
            cin>>w;
            v1.push_back(w);
        }
        for(int i=0; i<n; i++)
        {
            cin>>w;
            v2.push_back(w);
        }
        for(int i=0; i<k; i++)
        {
            cin>>w;
            v3.push_back(w);
        }
        for(int i=0; i<v2.size(); i++)
        {
            if(contains(v1,v2[i])&&!contains(v3,v2[i]))
                vcatch.push_back(v2[i]);
        }
        if(vcatch.empty())
            puts("No enemy spy");
        else
        {
            int i;
            for(i=0; i<vcatch.size()-1; i++)
                cout<<vcatch[i]<<" ";
            cout<<vcatch[i]<<endl;
        }
    }
    return 0;
}


我的水办法

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct  node
{
    char s[20];
    int flag1;
    int flag2;
}unit[10010];

int main()
{
    int i,j,k;
    int a,b,c;
    while(scanf("%d%d%d",&a,&b,&c)!=EOF)
          {

              for(i=0;i<a;i++)
              {
                  scanf("%s",&unit[i].s);
                  unit[i].flag1=0;
                  unit[i].flag2=0;
              }
              char h[20];
              for(i=0;i<b;i++)
              {
                  scanf("%s",h);
                  for(j=0;j<a;j++)
                  {
                      if(strcmp(h,unit[j].s)==0)
                      {
                          unit[j].flag1=1;//是spy
                          unit[j].flag2=1;//要带走
                      }
                  }

              }
               for(i=0;i<c;i++)
              {
                  scanf("%s",h);
                  for(j=0;j<a;j++)
                  {
                      if(strcmp(h,unit[j].s)==0)
                      {
                          unit[j].flag1=1;
                          unit[j].flag2=0;
                      }
                  }

              }
              /*for(i=0;i<a;i++)
              {
                  printf("%s %d %d\n",unit[i].s,unit[i].flag1,unit[i].flag2);
              }*/
              int num=0;
              for(i=0;i<a;i++)
              {
                  if((unit[i].flag1==1)&&(unit[i].flag2==1))
                  num++;
              }
              int c=num;
              int t=1;

              if(num==0)
              printf("No enemy spy\n");
              else
              if(num==1)
              {
                  for(i=0;i<a;i++)
                  {
                      if((unit[i].flag1==1)&&(unit[i].flag2==1))
                      {
                          printf("%s\n",unit[i].s);
                          break;
                      }
                  }
              }
              else
              {
                  for(i=0;i<a;i++)
                  {
                      if((t!=num)&&((unit[i].flag1==1)&&(unit[i].flag2==1)))
                      {
                         printf("%s ",unit[i].s);
                         t++;
                      }
                      else
                      if((t==num)&&((unit[i].flag1==1)&&(unit[i].flag2==1)))
                      printf("%s\n",unit[i].s);

                  }
              }


          }









    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值