Ice_cream’s world II hdu 2121 最小树形图

Ice_cream’s world II

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2465    Accepted Submission(s): 575


Problem Description
After awarded lands to ACMers, the queen want to choose a city be her capital. This is an important event in ice_cream world, and it also a very difficult problem, because the world have N cities and M roads, every road was directed. Wiskey is a chief engineer in ice_cream world. The queen asked Wiskey must find a suitable location to establish the capital, beautify the roads which let capital can visit each city and the project’s cost as less as better. If Wiskey can’t fulfill the queen’s require, he will be punishing.
 

Input
Every case have two integers N and M (N<=1000, M<=10000), the cities numbered 0…N-1, following M lines, each line contain three integers S, T and C, meaning from S to T have a road will cost C.
 

Output
If no location satisfy the queen’s require, you must be output “impossible”, otherwise, print the minimum cost in this project and suitable city’s number. May be exist many suitable cities, choose the minimum number city. After every case print one blank.
 

Sample Input
  
  
3 1 0 1 1 4 4 0 1 10 0 2 10 1 3 20 2 3 30
 

Sample Output
  
  
impossible 40 0
 

Author
Wiskey
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2120  2122  4009  2064  1997 




这个题目和2122相比其区别就在于是图是有向的,“ directed”已经很明显的说了,所以是最小树形图,唉
自己连这个都不能区分,还以为是最小生成树,还怎么好意思说自己是研究过图论呢????



那么这个题目应该怎么做,首先是套上最小树形图的模板,用朱刘算法来做就行,用0作为源点,建立下图





套上朱刘算法之后可以得出ans得出来加上0点之后的最小权值,再减去sum,也就是图里的71,就是没有0时的最小权值了,ansi得出来-m也就是得出了源点位置了



#include<stdio.h>
#include<string.h>
#include<math.h>
#define M 10007
#define inf 0x3f3f3f
using namespace std;
int pre[M],vis[M],id[M];
int in[M];
int n,m,ansi;

struct Node//建立邻接表
{
    int u,v;
    int cost;
}E[M*M+5];

int direct_mst(int root,int nv,int ne)
{
    int ret=0;
    while(true)
    {
        //找最小入边
        for(int i=0;i<nv;i++)
            in[i]=inf;
        for(int i=0;i<ne;i++)
        {
            int u=E[i].u;
            int v=E[i].v;
            if(E[i].cost<in[v]&&u!=v)
            {
                pre[v]=u;
                if(u==root)
                    ansi=i;
                in[v]=E[i].cost;
            }
        }
        for(int i=0;i<nv;i++)
        {
            if(i==root)continue;
            if(in[i]==inf)return -1;
        }
        //找环
        int cntnode=0;
        memset(id,-1,sizeof(id));
        memset(vis,-1,sizeof(vis));
        in[root]=0;
        for(int i=0;i<nv;i++)//标记每个环
        {
            ret+=in[i];
            int v=i;
            while(vis[v]!=i&&id[v]==-1&&v!=root)
            {
                vis[v]=i;
                v=pre[v];
            }
            if(v!=root&&id[v]==-1)
            {
                for(int u=pre[v];u!=v;u=pre[u])
                {
                    id[u]=cntnode;
                }
                id[v]=cntnode++;
            }
        }
        if(cntnode==0)break;//无环
        for(int i=0;i<nv;i++)
            if(id[i]==-1)
                id[i]=cntnode++;
        //缩点,重新标记
        for(int i=0;i<ne;i++)
        {
            int v=E[i].v;
            E[i].u=id[E[i].u];
            E[i].v=id[E[i].v];
            if(E[i].u!=E[i].v)
            {
                E[i].cost-=in[v];
            }
        }
        nv=cntnode;
        root=id[root];
    }
    return ret;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int u,v,w,sum=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            E[i].u=++u;
            E[i].v=++v;
            if(u!=v)
                E[i].cost=w;
            else
                E[i].cost=inf;
            sum+=w;
        }
        sum++;
        for(int i=0;i<n;i++)
        {
            E[m+i].u=0;
            E[m+i].v=i+1;
            E[m+i].cost=sum;
        }
        int ans=direct_mst(0,n+1,m+n);//n代表点的个数,m代表边的个数
        if(ans==-1||ans-sum>=sum)
            printf("impossible\n");//无法生成最小树形图
        else
            printf("%d %d\n",ans-sum,ansi-m);
        printf("\n");
    }
    return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值