Linux| 脚本运行错误(坏的解释器:没有那个文件或目录)

问题:
这里写图片描述

原因:
在Linux中有时候我们将在Windows下编写的脚本拷贝到Linux环境中运行时会出现运行不了的情况.
主要还是Windows的换行符为\r\n,而Linux环境中的换行符号为\n.

解决办法:
使用UE文本编辑工具将脚本文件所有的\r\n替换成\n既可.


方式二:
在执行脚本时,弹出错误提示:

/bin/sh^M:损坏的解释器: 没有那个文件或目录
1
这是由于脚本文件在保存时使用了DOS文件格式造成的,可以用vim打开文件,然后执行下列操作:

:set ff=unix
:wq
1
2
在windows下面编辑脚本,经常会碰到各种各样的坑,因此不推荐在windows下编辑脚本文件。若使用UltraEdit,默认打开的文件编码格式是简体中文GBK,最好切换成utf8格式。
设置方法如下:
高级 —- 设置 —- 文件处理 — DOS/Unix/Mac处理 ,将”新建文件的默认类型”改为”UNIX”即可。

windows下编辑代码真坑,Android Studio不是utf8格式一直编译不过去,用Notepad++切换编码格式也不行,造成APK界面乱码。
winodws下推荐使用Sublime Text,代码高亮比较全,界面简洁,或者使用UltraEdit,不过切记:使用UltraEdit,一定、一定、一定(重要的事情说三遍)要将UltraEdit的默认文件类型改为”UNIX”

发布了456 篇原创文章 · 获赞 152 · 访问量 45万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 技术黑板 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览