杭电1513(Palindrome)

9 篇文章 0 订阅
8 篇文章 0 订阅

点击打开杭电1513

Problem Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input

  
  
5 Ab3bd
 

Sample Output

  
  
2

题意:

给出一个字符串,问让此字符串变成一个回文串最少要加多少个字符


思路:

将此字符串倒序所得的字符串与本身进行lcs,用n减去所求的最长公共子序列的长度就是答案


代码:

import java.util.*;
class P1513{
    static String str;
    static char[] str1;
    static char[] str2;
    static int n;
    static int[][] dp;
    public static void main(String[] args){
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){
            n=sc.nextInt();
            str2=new char[n];
            str1=new char[n];
            str=sc.next();
            str1=str.toCharArray();
            for(int i=0;i<n;i++){
                str2[i]=str1[n-i-1];
            }
            lcs();
            System.out.println(n-dp[n%2][n]);
        }
    }
    public static void lcs(){
        int i,j;
        dp=new int[n+1][n+1];
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++){
            	int x=i%2;
            	int y=1-x;
                if(str1[i-1]==str2[j-1]){
                    dp[x][j]=dp[y][j-1]+1;
                }else{
                    dp[x][j]=Math.max(dp[y][j], dp[x][j-1]);
                }
            }
        }
    }
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值