POJ 3518 简单素数打表

38 篇文章 0 订阅
Prime Gap
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8091 Accepted: 4748

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114


题意:给你一个数N,输出这个数相邻的素数的差。。。
当然,自己是素数就直接输出零了。。
水题,直接打表找。。这题是13的小孩在做周赛时无聊的时候随手写的。。大概15分钟写完了,血淋淋的T了3次= = 后面脑残的发现预处理位置放错了,导致每次输入N的时候
都预处理了,不T才怪o(╯□╰)o。。。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
long long   is_prime[1500005];
long long  prime[1500005];
long long n;
int k;
void dabiao()
{
    memset(is_prime,0,sizeof(is_prime));
    is_prime[0]=is_prime[1]=1;
    for(long long  i=2;i<=1299709;i++)
    {
        if(is_prime[i]==1)
        {
            continue;
        }
        for(long long j=2*i;j<=1299709;j+=i)
        {
            is_prime[j]=1;
        }
    }
     k=0;
    for(int i=2;i<=1299709;i++)
    {
        if(is_prime[i]==0)
        {
            prime[k++]=i;
        }
    }
}


int main()
{
     dabiao();
    while(scanf("%I64d",&n)!=EOF)
    {
        if(n==0)
            break;

        if(is_prime[n]==0)
        {
           printf("0\n");
            continue;
        }

        else
        {
            for(int i=0;i<=k;i++)
            {
                if(prime[i]<n&&prime[i+1]>n)
                {
                    printf("%I64d\n",prime[i+1]-prime[i]);
                    break;
                }
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值