Prime Gap

Prime Gap
Crawling in process... Crawling failed Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u       

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114
//做过前面的素数的问题,本题还是比较简单的,就是数据有点大,应该可以优化吧!暂时不知道该怎么优化。欢迎来大家讨论奋斗
#include<iostream>
using namespace std;

long long f[1300000],prime[1000000];
long count = 0;
void Prime()
{
	
	for(long long  i=2;i<=1300000;i++)
		if(!f[i])
		{
			prime[count++]=i;
			
			for(long long j=i*i;j<=1300000;j+=i)
				f[j]=1;
		}
	//cout<<prime[0]<<endl;
	//		cout<<prime[1]<<endl;
}
int main()
{
	Prime();
	long long n,t1,t2;
	while(cin>>n&&n)
	{
		for(long long i=n;i>0;i--)
		{
			if(!f[i])
			{
				t1=i;
				//cout<<t1<<endl;
				break;
			}
		}
		for(long long j=n;;j++)
		{
			if(!f[j])
			{
				t2=j;
				//cout<<t2<<endl;
				break;
			}
		}
		cout<< t2-t1<<endl;
	}
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值