【POJ】[1985]Cow Marathon

Cow Marathon

Time Limit: 2000MS Memory Limit: 30000K
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.
Input

  • Lines 1…..: Same input format as “Navigation Nightmare”.
    Output

  • Line 1: An integer giving the distance between the farthest pair of farms.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.


给一个树,让寻找树中两点的最大距离
也就是求树的直径

思路:找出任意一点的最远点u,在找出u的最远点v,则n-v的距离即是最大距离。

可以运用DFS||BFS来进行搜索
因为时间类似而DFS比较简洁
所以这里运用DFS

储存树使用了邻接表

#include<stdio.h>
#include<string.h>
int n,m;
int t,res;
int head[100200];
int headcnt;
struct List {
    int u,v,w;
    int next;
} edge[100200];
void dfs(int u,int v,int w) {
    if(w>res) {
        res=w;
        t=u;
    }
    for(int i=head[u]; i!=-1; i=edge[i].next) {
        if(edge[i].v!=v) {
            dfs(edge[i].v,u,w+edge[i].w);
        }
    }
}
void add(int u,int v,int w) {
    edge[headcnt].u=u;
    edge[headcnt].v=v;
    edge[headcnt].w=w;
    edge[headcnt].next=head[u];
    head[u]=headcnt++;
}
int main() {
    while(scanf("%d %d",&n,&m)!=EOF) {
        headcnt=0;
        memset(head,-1,sizeof(head));
        while(m--) {
            int u,v,w;
            scanf("%d %d %d %*c",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }
        res=0;
        dfs(1,0,0);
        dfs(t,0,0);
        printf("%d\n",res);
    }
    return 0;
}

题目地址:【POJ】[1985]Cow Marathon

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值