hdu1116&poj1386 并查集加欧拉路径的判断

Play on Words

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4216 Accepted Submission(s): 1363


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.

Source

Recommend
Eddy

Statistic | Submit | Discuss | Note
//此题大意是给出一些字符串看是否能接龙连接下去。将此题转化为判断是否存在欧拉路径。26个字母为节点,
//而每个字符串就是路径,转化为有向图。然后判断是否存在欧拉路径。欧拉路径的判断方法:
//1.首先图要是连通图,所以用并查集判断。
//2.有向图存在欧拉路径条件:只有一个点的的入读比出度大一,只有一个点的出度比入度大一,其余点的出度
//等于入度。另外存在欧拉回路的条件是所有点出度等于入度。
 
#include <iostream>
#include <string>
#include <cstring>
using namespace std;
typedef class Str
{
public:
    char num;
    int in,out;
}S;
S s[26];
int p[26];
bool pp[26];
int fa[26];
int FIND(int x)
{
    return p[x]==x?x:FIND(p[x]);
}
bool exist_eulerpath(int n)
{
    int i;
    int flag;
    memset(fa,-1,sizeof(fa));
    bool ss=true,ee=true;
    for(i=0;i<26;i++)
    {
        if(pp[i])
            flag=fa[i]=FIND(i);
        if(s[i].in>s[i].out)
        {
            if(s[i].in-s[i].out<=1&&ee)
                ee=false;
            else
                return false;
        }
        else if(s[i].in<s[i].out)
        {
            if(s[i].out-s[i].in<=1&&ss)
                ss=false;
            else
                return false;
        }
    }
    if(ss!=ee)
        return false;
    for(i=0;i<26;i++)
        if(pp[i]&&fa[i]!=flag)
            return false;
    return true;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        int i,j;
        for(i=0;i<26;i++)
        {s[i].in=0;s[i].out=0;s[i].num='a'+i;p[i]=i;pp[i]=false;}
        for(i=0;i<n;i++)
        {
            string a;
            cin>>a;
            pp[a[0]-'a']=true;
            pp[a[a.size()-1]-'a']=true;
            int x=FIND(a[0]-'a'),y=FIND(a[a.size()-1]-'a');
            if(x!=y)p[x]=y;
            for(j=0;j<26;j++)
            {
                if(s[j].num==a[0])
                    s[j].out++;
                if(s[j].num==a[a.size()-1])
                    s[j].in++;
            }
        }
        if(exist_eulerpath(n))
            cout<<"Ordering is possible."<<endl;
        else
            cout<<"The door cannot be opened."<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值