青年歌手大奖赛_评委会打分
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44112 Accepted Submission(s): 21971
Problem Description
青年歌手大奖赛中,评委会给参赛选手打分。选手得分规则为去掉一个最高分和一个最低分,然后计算平均得分,请编程输出某选手的得分。
Input
输入数据有多组,每组占一行,每行的第一个数是n(2<n<=100),表示评委的人数,然后是n个评委的打分。
Output
对于每组输入数据,输出选手的得分,结果保留2位小数,每组输出占一行。
Sample Input
3 99 98 97
4 100 99 98 97
Sample Output
98.00
98.50
分析
求最大数 max 和最小数 min 的时候,可以先初始化 max = -1;min = 101;然后通过比较判定得出最终的 max 和 min
算法代码
import java.text.DecimalFormat;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
DecimalFormat df = new DecimalFormat("0.00");
Scanner scanner = new Scanner(System.in);
while (scanner.hasNext()) {
int n = scanner.nextInt();
int min = 101, max = -1;
float sum = 0;
for (int i = 0; i < n; i++) {
int temp = scanner.nextInt();
if (min > temp) min = temp;
if (max < temp) max = temp;
sum += temp;
}
float avg = (sum - min - max) / (n - 2);
System.out.println(df.format(avg));
}
}
}