HDU1026 Ignatius and the Princess I 解题报告--bfs

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9811    Accepted Submission(s): 2928
Special Judge


Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
 

Author
Ignatius.L
#include<iostream>
#include<queue>
using namespace std;
int n,m,flag;//行列数,标志
int Ti;//最终时间
int go[4][2]={0,1,1,0,0,-1,-1,0};//方向
char map[121][121];//迷宫
int mark[121][121];//标记
int fight[121][121];//打斗时间
struct s//优先队列结构体
{
	int x,y,t;
	friend bool operator<(s a,s b)
	{
		return a.t>b.t;
	}
};	
s orz[151];int c;//orz用来存放最终路径,c是计数器
priority_queue<s>q;
void bfs()//广搜
{
	while(!q.empty())
		q.pop();
	flag=0;
	s a,b;
	a.x=0;a.y=0;a.t=0;//从0,0出发
	mark[0][0]=1;
	q.push(a);//进入队列
	int i;
	while(!q.empty())//当队列不为空时循环
	{
		a=q.top();//队列头
		q.pop();	//左进右出
		if(a.x==n-1&&a.y==m-1)//如果达到终点输出结果记下时间和标志
		{
			printf("It takes %d seconds to reach the target position, let me show you the way.\n",a.t);
			Ti=a.t;
			flag=1;
			break;
		}
		else
		{
			for(i=0;i<4;i++)//四个方向搜索
			{
				b=a;
				b.x=a.x+go[i][0];
				b.y=a.y+go[i][1];//孩子坐标
				if(b.x>=0&&b.x<n&&b.y>=0&&b.y<m&&map[b.x][b.y]!='X'&&mark[b.x][b.y]==0)//在范围里且不为墙没被走过
				{
					if(map[b.x][b.y]>'0'&&map[b.x][b.y]<='9')//如果是boss
					{
						int tt=map[b.x][b.y]-'0';//计算打boss的时间
						b.t=a.t+tt;//计数器加上打boss时间,这样不可以!!!!!!!!a.t=a.t+tt
						fight[b.x][b.y]=tt;//打斗时间
					}
					mark[b.x][b.y]=1+i;//标记走方向
					b.t=b.t+1;//.要走1个时间这样不可以!!!!!!!!b.t=a.t+tt
					q.push(b);//
				}
			}
		}
	}
	if(flag==0)
		printf("God please help our poor hero.\n");//如果搜索结束没成功输出这个
	return ;
}
int cmp(int x,int y)//函数,调出走的轨迹
{
	if(c==0) return 0;//如果走到最后结束
	else
	{
		c--;//c从最终时间开始
		orz[c].x=x;orz[c].y=y;//记下轨迹
		for(int i=0;i<fight[orz[c].x][orz[c].y];i++)//如果有打斗,在这时间内坐标不变
		{		
			c--;
			orz[c].x=x;
			orz[c].y=y;
		}
		int nx=x-go[mark[x][y]-1][0];
		int ny=y-go[mark[x][y]-1][1];//回溯,通过方向
		cmp(nx,ny);//再循环
	}
}
int main()
{
	while(~scanf("%d %d%*c",&n,&m))
	{
		memset(mark,0,sizeof(mark));
		memset(map,0,sizeof(map));
		memset(fight,0,sizeof(fight));
		int i,j;
		char v;
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				scanf("%c",&map[i][j]);
			}
			scanf("%c",&v);
		}//输入
		bfs();
		if(flag==1)//如果成功输出路径
		{
		c=Ti+1;
		cmp(n-1,m-1);	
		orz[0].x=0;orz[0].y=0;//出发位置是0,0
		int tt=1;//秒数
		for(i=0;i<Ti;i++)
		{
			if(fight[orz[i].x][orz[i].y]==0)//如果没发生打斗
				printf("%ds:(%d,%d)->(%d,%d)\n",tt++,orz[i].x,orz[i].y,orz[i+1].x,orz[i+1].y);//输出这个时间的出发到达点
			else
			{
				for(j=0;j<fight[orz[i].x][orz[i].y];j++)
					printf("%ds:FIGHT AT (%d,%d)\n",tt++,orz[i].x,orz[i].y);//输出打斗次数
				if(tt-1==Ti)//如果打斗后就是结束,结束跳出
					break;
				else//否则输出打斗后的一步
				{
					printf("%ds:(%d,%d)->(%d,%d)\n",tt++,orz[i+j].x,orz[i+j].y,orz[i+j+1].x,orz[i+j+1].y);
				i+=j;//打斗时间要跳过
				}
			}
		}
		}
		printf("FINISH\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值