ACM之Ignatius and the Princess IV解题报告

          Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 6624 Accepted Submission(s): 2369

Problem Description
“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…” feng5166 says.

Can you find the special integer for Ignatius?

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output
For each test case, you have to output only one line which contains the special number you have found.

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

三种不同的思路,解法。

count为计数器,初始值为1。
定义一个函数,函数功能为:
在n个数中找出总个数大于等于(n+1)/2的数。先将该n个数用sort从小到大排序,然后从第一个数P[i](i=0,开始,依次拿后面的数与之比较是否相等,相等则count++,循环进入下一个数,不相等则跳出循环,判断此时的计数器count是否>=(n+1)/2,满足条件则返回此时的P[i],不满足则i=count+i,计数器count重置为1.初始为P[count+i],继续循环,直到最后一个数比较完。

#include <iostream>
#include <algorithm>
using namespace std;
int B[10][1000000];                 //选择在main函数外定义全局数组,在函数内能定义的长度较小
int find(int P[],int n)
{
    int i=0,count=1;
    for(;i<n;){

    {
        if(P[i]==P[i+count]&&i+count<=n-1) count++;
        else break;
    }
    if(count>=(n+1)/2) return P[i];
  else {i=count+i;count=1;}
    }
}
int main()
{

    int A[10000],i=0,n,j;

    while(cin>>A[i])
    {
        for(j=0;j<A[i];j++) cin>>B[i][j];
        i++;
    }
    n=i;
   for(i=0;i<n;i++){
       sort(B[i],B[i]+A[i]);
         cout<<find(B[i],A[i])<<endl;
}

    return 0;
}

这种解法虽然结果正确,但是提交之后超时。暂未找到简化算法,避免超时的方法。


注:该思路来源于其他博主,在此引用
/*
多元素即在数列中出现次数多于n/2的元素

我们很容易的看出来,在一个序列中如果去掉2个不同的元素,那么原序列中的多元素,在新的序列中还是多元素,因此我们只要按照序列依次扫描,先把t赋值给result,增加个计数器,cnt = 1;然后向右扫描,如果跟result相同,则cnt++,不同,那么cnt --,
这个真是我们从上面那个结论里得出的,一旦cnt == 0了,那么必定c不是多元素,这个时候把t赋值为result,cnt = 1;,重复该过程,知道结束,这个时候,result就是多元素,这个的时间复杂度为n,该题本来可以用数组保存每个元素,然后递归上述过程,可是,用数组超内存,因此我们可以直接按照上述过程计算

*/

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int result,cnt,t,n,i;
    while(scanf("%d",&n)!=EOF)
    {
        cnt=0;
      for(i=0;i<n;i++)
        {scanf("%d",&t);
            if(cnt==0)
            {
                cnt=1;
                result=t;
            }
            else if(cnt!=0){
                if(t==result) cnt++;
                else cnt--;
            }
        }
        printf("%d\n",result);
    }
    return 0;
}


还有一种更简单的思路,由于n<=999999,(n+1)/2最多为500000,定义一个数组map[500001],每次输入一个数t,map[t]++,即相应位置的数组上的元素加1,如果map[t]>=(n+1)/2 ,则t即为满足条件的数。

#include<stdio.h>
#include<cstring>
int map[500001];
int main()
{
int n,i,a,max;
while(scanf("%d",&n)!=EOF)
{
memset(map,0,sizeof(map));
for(i=0;i<n;i++)
{
scanf("%d",&a);
map[a]++;
if(map[a]>=(n+1)/2)
max=a;
}
printf("%d\n",max);
}
return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值