POJ3259 Wormholes 解题报告--bellman_ford

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25153 Accepted: 8973

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

#include<iostream>
#define inf 0xfffff
using namespace std;
struct s
{
	int begin,end,time;
}edge[2600];
		int n,m,h;
bool bellman_ford()
{
	int flag=0,i,j,k;
	int c=1;
	int dis[1001];
	for(i=1;i<=n;i++)
		dis[i]=inf;//设虚拟点到各点的距离为无穷大
	for(i=0;i<n;i++)//循环n-1次
	{
		flag=0;
		if(c++>n) break;
		for(j=1;j<=m;j++)//m是道路条数
		{
			if(dis[edge[j].begin]>dis[edge[j].end]+edge[j].time)//更新如0到1是否大于0到2再到1
			{
				dis[edge[j].begin]=dis[edge[j].end]+edge[j].time;
				flag=1;//说明有更新
			}
			if(dis[edge[j].end]>dis[edge[j].begin]+edge[j].time)//反向更新
			{
				dis[edge[j].end]=dis[edge[j].begin]+edge[j].time;
				flag=1;
			}
		}
		for(;j<=m+h;j++)
		{
			if(dis[edge[j].end]>dis[edge[j].begin]-edge[j].time)
			{
				dis[edge[j].end]=dis[edge[j].begin]+-edge[j].time;
				flag=1;
			}
		}
		if(flag==0) break;//如果循环一次无法更新则说明虫洞的负权不起作用,这时光倒流不可能完成
	}
		return flag;//因为这是bool函数所以返回值只有1和0,这里1说明可行
		//flag始终是1说明可以循环下去直到成为负环,负环即是时光倒退符合题意
}
int main()
{
	int r;
	scanf("%d",&r);
	while(r--)
	{
		scanf("%d%d%d",&n,&m,&h);//总数,接下来道路数,虫洞数
		int i,j;
		for(i=1;i<=m+h;i++)
		{
			scanf("%d%d%d",&edge[i].begin,&edge[i].end,&edge[i].time);//把map[a][b]=c中的abc放到一个点中
			//因为把ab都放入一个点中,这表示a到b和b到a都是存为time的c
		}
		if(bellman_ford())//判bell
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值