E - Neighbor House

Description

The people of Mohammadpur have decided to paint each of their houses red, green, or blue. They've also decided that no two neighboring houses will be painted the same color. The neighbors of house i are houses i-1 and i+1. The first and last houses are not neighbors.

You will be given the information of houses. Each house will contain three integers "R G B" (quotes for clarity only), where R, G and Bare the costs of painting the corresponding house red, green, and blue, respectively. Return the minimal total cost required to perform the work.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case begins with a blank line and an integer n (1 ≤ n ≤ 20) denoting the number of houses. Each of the next n lines will contain 3 integers "R G B". These integers will lie in the range [1, 1000].

Output

For each case of input you have to print the case number and the minimal cost.

Sample Input

2

 

4

13 23 12

77 36 64

44 89 76

31 78 45

 

3

26 40 83

49 60 57

13 89 99

Sample Output

Case 1: 137

Case 2: 96

#include<stdio.h>
#include<algorithm>
using namespace std;
#define inf 10e8
int a[25][5];
int dp[25][5];
int main()
{
	int r,n,ca=1;
	scanf("%d",&r);
	while(r--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		   for(int j=1;j<=3;j++)
		   {
   			   scanf("%d",&a[i][j]);
   			   dp[i][j]=inf;
   		   }
		      
		int sign=0;      
        for(int i=1;i<=n;i++)
        {
        	for(int j=1;j<=3;j++)
        	{
        		for(int k=1;k<=3;k++)
        		{
		        	if(k!=j)
		        	dp[i][j]=min(dp[i][j],dp[i-1][k]+a[i][j]);
		        } 
		        
	        }
        
        }
        int ans=inf;
        for(int i=1;i<=3;i++)
           if(dp[n][i]<ans)
           {
           	  ans=dp[n][i];  
           }
		     
			                  
        printf("Case %d: %d\n",ca++,ans);    
	}
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值