D - Throwing Dice

这题有空再看看

Description

n common cubic dice are thrown. What is the probability that the sum of all thrown dice is at least x?

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n < 25) and x (0 ≤ x < 150). The meanings of n and x are given in the problem statement.

Output

For each case, output the case number and the probability in 'p/q' form where p and q are relatively prime. If q equals 1 then print p only.

Sample Input

7

3 9

1 7

24 24

15 76

24 143

23 81

7 38

Sample Output

Case 1: 20/27

Case 2: 0

Case 3: 1

Case 4: 11703055/78364164096

Case 5: 25/4738381338321616896

Case 6: 1/2

Case 7: 55/46656

#include <cstdio>
#include <cstring>
int n,m,p[25];
long long v,sum,dp[30][150];
long long gcd(long long a,long long b)
{
    if(a%b==0) return b;
    else return gcd(b,a%b);
}
int main()
{
    int r,ca=1;
    scanf("%d",&r);
    while(r--)
    {
	    scanf("%d%d",&n,&m);
        if(!n&&!m) break;
        if(n>=m) printf("Case %d: 1\n",ca++);
        else if(n*6<m) printf("Case %d: 0\n",ca++);
        else
        {
            v=1,sum=0;
            for(int i=0; i<n; ++i) v=v*6;
            
            memset(dp,0,sizeof(dp));
            
            for(int i=0; i<=6; ++i) dp[0][i]=1;
            
            for(int i=0; i<n-1; ++i)
                for(int j=1; j<=(i+1)*6; ++j)
                    for(int k=1; k<=6; ++k)
                    	dp[i+1][j+k]+=dp[i][j];
                    
            for(int i=m; i<=n*6; ++i) 
			    sum=sum+dp[n-1][i];	
						    
            long long c=gcd(v,sum);   
            printf("Case %d: %lld/%lld\n",ca++,sum/c,v/c);  //I64d 
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值